1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

faze tach illumination not working

Discussion in 'ECU's, Electronics, and Tuning' started by HATCHET_HONDA, Dec 3, 2007.

  1. HATCHET_HONDA

    HATCHET_HONDA scottie fizzle

    Messages:
    764
    Likes Received:
    10
    Joined:
    Mar 11, 2007
    Location:
    hobart, indiana
    so i bought this 5in faze tach off ebay when i did my d15b swap in the ef.....its been workin great!...well now the damn thing only lights up when i first turn on the headlights, then goes out when the tach needle starts to move..wtf?
     
  2. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    how do you have it wired???
    red to________(where does it pull power from)
    black to_________(where is it grounded at)
    green to______(tach adaptor,wired into factory tach wire or the green wire on the dizzy)
    white to_________(whats illuminating it,switch ran to power wire,headlight switch??
     
  3. HATCHET_HONDA

    HATCHET_HONDA scottie fizzle

    Messages:
    764
    Likes Received:
    10
    Joined:
    Mar 11, 2007
    Location:
    hobart, indiana
    mechanicly it works fine..just the backlight goes off and on. i have tested the power wire (which is tapped into the parking light circuit) with a test light and its gettin juice so idk...
     
  4. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    maybe a loose connection in the tach itself..try to return it..tell them it wont light up
     
Verification:
Draft saved Draft deleted

Share This Page