1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Finished B16 swap

Discussion in 'HYBRID -> EG-EK / DC' started by Nick7, Jan 12, 2005.

  1. Nick7

    Nick7 Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Jul 25, 2003
    Yesterday finally completed my B16A2 swap.
    Donor engine is B16A2, OBD1, car put into '97 Civic (6th gen). Previous engine -> turbocharged D14A4
    1st problem was my wiring harness -> OBD2 that I had needed to be replaced, since D14 has some weird wiring (firing injectors in paris, ECU connectors completely different from 'standard' OBD2), etc, etc...
    2nd problem -> to find OBD2 wire harness here it's pretty damn hard (Croatia, Europe)
    solution: use engine wire harness that's OBD1, OBD1 ECU, OBD1 fuse boxes (underhood & underdash), rest is OBD2 cabling -> meaning LOTS of rewiring needed to be done.
    Mechanic had easy job to swap out D14 with B16, but another probem - he didn't have rear engine mount bracket!
    Rewiring took some time, but after some time, I managed to rewire everything. Yay!
    However, car had to stay parked in garage to still missing rear engine mount bracket...
    Than this weekend I had to drive short distance to install back my alarm, and on way back home - car just died... - no spark! It turned out that coil was gone. Fixed.
    And finally - yesterday put in rear engine mount bracket!

    *Finally* I was able to test drive it! :)
    Sweet! It pulls nicely, VTEC kicks in at 5500, and sound that makes afterwards at 6000, 7000rpm is just friggin' amazing! It just asks to be reved all the time! It's also kewl to look at stock tach which is engraved only to 8k :)

    All in all, it was some pain, overall it took about month and a half for swap, mostly due to missing rear engine mount bracket. But now it works. That's most important thing :)

    I have one problem though - car 'shakes' a bit when accelerating, mostly noticable at 40-50mph. It's due to bad axle, as it seems left axle. I'll have it replaced ASAP tho.. but all other seems to be good.

    Yet another hybrid rollin' down the street.. half OBD1, half OBD2... :)

    And few pics...

    Before
    [​IMG]

    Now (photo was taken before some time.. so wires are still hanging arround and AC is not in on this pic yet.. need new pics! :D)
    [​IMG]

    And some WIP with wiring (all done & working now):
    [​IMG]
    [​IMG]
     
  2. socolsvtec

    socolsvtec Member

    Messages:
    34
    Likes Received:
    0
    Joined:
    Oct 6, 2004
    Location:
    colorado
    looks good.. i got same thing in 98 hx, but rewired to obd1 using p30 ecu.
     
  3. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    54
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
  4. glada96EX

    glada96EX Junior Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Dec 18, 2005
    I know this is an old post, but how did you rewire so you could use the obd2 harness with the obd1 dizzy??? I doing similar swap and thats where im stuck right now.
     
Verification:
Draft saved Draft deleted

Share This Page