1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fuel Pressure Regulator Failure

Discussion in 'General Tech and Maintenance' started by luVTEC, May 27, 2003.

  1. luVTEC

    luVTEC Senior Member

    Messages:
    198
    Likes Received:
    0
    Joined:
    Feb 28, 2003
    I have been having some fuel related problems with my CRX and I suspect its my fuel pressure regulator. My question is what are some symptoms of a bad FPR? anybody ever had one fail? :huh:


    see below for full description...

    If your interested I'll bring you up to speed on whats happended. My CRX had been having problems starting until one day it just died. I noticed that there was no smell of gas when I cranked it over b/c I had the intake off. I disconnected the fuel line at the filter (from the pump) and shure enough...no gas would come out when I cranked it. <_<

    I figured it was either a bad fuel relay or pump (the pump was replaced only two yrs ago). I tested the relay and the relay harness first, it checked out. I removed the fuel pump and tested it, it worked fine. I blew air through the fuel lines to see if they were blocked, nope they were fine. I put everthing back together and it worked :blink: , not knowing what it was I replaced the fuel relay anyway <_< .

    It worked fine for a day then it began to loose power under load. The CEL came on and it threw a CODE 1 O2 sensor? Now it won't star at all? the fuel pump won't pump when the key is truned? WTF? I got a new fuel filter too. The only original parts of the fuel sytem left are the injectors and the pressure regulator, so I suspect the regulator.

    please help if you know thanks.
     
  2. kingwilly

    kingwilly Senior Member

    Messages:
    349
    Likes Received:
    0
    Joined:
    Mar 10, 2003
    Location:
    arizona
    check your grounds..sounds to like an electrical problem..check all connections too
     
  3. luVTEC

    luVTEC Senior Member

    Messages:
    198
    Likes Received:
    0
    Joined:
    Feb 28, 2003
    oh yeah, I forgot to mention i went through all the grounds for the engine and fuel system, they looked clean , but I cleaned them up anyway.


    thanks for the reply though
     
Verification:
Draft saved Draft deleted

Share This Page