1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

fuel pump problems

Discussion in 'Civic and CRX - EF' started by Ky'sCRX, Jun 13, 2007.

  1. Ky'sCRX

    Ky'sCRX New Member

    Messages:
    125
    Likes Received:
    0
    Joined:
    Oct 11, 2006
    Location:
    Shepherdsville, Ky
    i have this problem before, every once in awhile my fuel isnt kicking on. i have replaced the pump and the relay, it was fine for awhile then just stoped one day and the next day it was fine. but now its completly dead. has any one else had this problem
     
  2. Sadistik

    Sadistik New Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    May 24, 2007
    Location:
    Northern Kentucky
    Check wires for a short. Also, make sure the pump is getting a good ground.
     
  3. welfare

    welfare Ancient Member

    Messages:
    1,120
    Likes Received:
    9
    Joined:
    Apr 19, 2004
    Location:
    New York
    PGMFI main relay may be bad. . . OR it could be a ground like sadistik said.
     
  4. 1.8crx

    1.8crx New Member

    Messages:
    39
    Likes Received:
    15
    Joined:
    Oct 8, 2006
    I take it you got your problem fixed, since its been a couple weeks since you've said anything. I swapped my fuel pump out about 2 weeks ago and it ran for a lil, and than nothing. My fuel pump would kick on, but no fuel under my hood. I found out when we put my tank back up, i had a hose that got twisted and kinked up, i undid a few bolts and spun it around and put it back on. problem fixed.
     
Verification:
Draft saved Draft deleted

Share This Page