1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fuel Pump

Discussion in 'General Tech and Maintenance' started by mozzandherb, Sep 29, 2005.

  1. mozzandherb

    mozzandherb Senior Member

    Messages:
    305
    Likes Received:
    0
    Joined:
    Jun 21, 2005
    I just swapped an h22 into my 92 Accord and I'm looking to upgrade the fuel pump. Which one should I go with? The Walboro 255? Does anyone know if the Walboro is an in-line pump for the Accord and is it a pain in the ass to add?
     
  2. Cashizslick

    Cashizslick !i!i!i!i!i!i!i!i!i!i!i!

    Messages:
    5,751
    Likes Received:
    37
    Joined:
    Aug 15, 2003

    The walbro 255 would be overkill for the mods on your car now. If you are going to continue modifying the car I would suggest using the walbro 255lph or even the 190lph depending on what you are going to be running.
     
  3. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    Great pump, just wont need it until you upgrade injectors...the 330s? on the H22 wont tax your accord at all.
     
  4. mozzandherb

    mozzandherb Senior Member

    Messages:
    305
    Likes Received:
    0
    Joined:
    Jun 21, 2005
    I guess the main reason right now I want to upgrade is because even when I had the f22 once and a while my car wouldn't start right away, and now with the swap it's doing the same thing, so I'm kinda guessing it's the fuel pump since that wasn't changed with the swap. In the future nect year I plan on adding boost and the mods I have right now are pretty basic i/h/e, fuel rail and that's about it.
     
  5. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    in ooooooo id GUESS 90% of no start hondas...its the main relay.
     
  6. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    Wow...i didnt think someone would agree with me...

    I know in my brothers civic, (EF) an EG that a friend has, an accord that a co-worker has, the cars didnt start because the solder had cracked on the relay.
     
  7. VTECPOWER

    VTECPOWER Senior Member

    Messages:
    1,683
    Likes Received:
    0
    Joined:
    Oct 6, 2003
    Location:
    Winchester, VA
    :werd: (again)
    Main Relay's on honda's always seem to fuck up.
    Happened on my many of my family's honda's (we all drive em) and some friends cars.
     
Verification:
Draft saved Draft deleted

Share This Page