1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Gauge Cluster Swap

Discussion in 'Civic and del Sol - EG and EK' started by Bnutz, Aug 31, 2011.

  1. Bnutz

    Bnutz New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Feb 11, 2009
    I have a '94 Civic DX. I didn't want to add an aftermarket tachometer unless my first choice didn't work. I bought a cluster from the junkyard that had a tach and installed it. Everything works but the tach and the speedometer. The tach jumps slightly at idle but the speedometer doesn't move. Should they have automatically worked when installed or is there a fuse or connection I need to hook up? Or how can I tell if they are broken? All help is appreciated!

    B
     
  2. TurboMirage

    TurboMirage YEEAAAHHH VIP

    Messages:
    24,580
    Likes Received:
    696
    Joined:
    May 20, 2003
    Location:
    Central, MA
    should work fine. when i had my 92 DX, i swapped my speedometer (for mileage) into an EX cluster, plug and play.
     
  3. Bnutz

    Bnutz New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Feb 11, 2009
    Thanks...I think the needles were stuck. They both work fine now.
     
  4. Rudhart89HB

    Rudhart89HB HatchBacker

    Messages:
    24
    Likes Received:
    0
    Joined:
    Sep 1, 2011
    Location:
    Frankfort, Ky
    with gauges like that, are the hookups for the tach behind the gauge plate? i dont have a "onboard" tach either, i installed an after market one
     
Verification:
Draft saved Draft deleted

Share This Page