1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Got Problems: Little Bit of Everything

Discussion in 'General Tech and Maintenance' started by bafbrian, May 17, 2007.

  1. bafbrian

    bafbrian New Member

    Likes Received:
    Nov 6, 2006
    Atlanta, GA
    I am helping a friend out who just the car back from Mainstream the other day, btw Mainstream, [​IMG] on the fix, would have been screwed without that quick thinking from you guys on fixing that thing for Dwayne.

    Anyway, its a 99 with a gsr swap running a greddy turbo kit. 3 shops later and Mainstream is the only shop to do good work on the car.

    Got the car to my house to work on it and after replacing the spark plugs (oil in the chambers), replacing the wires (old ones drenched in oil), and replacing the ignition coil, did i finally get his car to start again.

    I got the running all day today but, it still idles at a little over 2k, the battery is getting killed by something (alternator ground ?), and now there is this annoying ass beep coming from the passenger side of the car.

    Really need some help on this.

    YBLEGAL Regular Member w/ Cheese

    Likes Received:
    Aug 9, 2006
    NW Indiana
    a beep from the <u>passenger</u> side?? since you have oil everywhere, maybe it's time to replace as many gaskets as you can. how long have u ran the turbo kit? previous problems? vacuume lines of course...; i'm just guessing.

    here's a bump for ya. g'luck
Draft saved Draft deleted

Share This Page