1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Grinding noise from ecu/ wont crank

Discussion in 'Civic and del Sol - EG and EK' started by maksym_3, Mar 22, 2008.

  1. maksym_3

    maksym_3 Junior Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Feb 2, 2006
    Hey, so i recently did the suspension on my car, while it was in the garage the battery died and so i charged it with one of those "master craft power chargers". Today i tried to start it and it wont crank. The radio turns on fine, lights everything but when i try to turn it over the radio dies, it clicks and sometime the ecu makes some weird noise(at least im thinking its from the ecu).

    Any help would be greatly appreciated thanks

    This is a 97 ek hatch cx btw
     
  2. HondaElite

    HondaElite senior member

    Messages:
    135
    Likes Received:
    1
    Joined:
    Nov 2, 2006
    Location:
    fall river.mass
    could have fried the ecu..or have a bad ground..i recently had some grounding issues..car ran fine all of a sudden it wanted more ground..but try grounding it...and if not then ty a different ecu..good luck
     
  3. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    sounds like the battery is just to weak
     
  4. LS_VTEC

    LS_VTEC you get the BRAKE

    Messages:
    2,616
    Likes Received:
    25
    Joined:
    Dec 11, 2007
    Location:
    NJ
    Check your battery terminals. Clean them up with a wire brush and then tighten them back down. Keep in mind, you can have 12.6v at the battery, but without enough CCA's it will not turn the starter over. Have the battery tested at a local shop or chain shop such as PepBoys, AutoZone, StraussAuto... etc.
     
  5. dtob

    dtob New Member

    Messages:
    578
    Likes Received:
    2
    Joined:
    Mar 18, 2007
    Ya that's your solenoid pulling in then letting go.
     
  6. jOnZ

    jOnZ JDM jOn

    Messages:
    73
    Likes Received:
    0
    Joined:
    Aug 17, 2006
    NO.

    Try another battery. I am also assuming the clicking noise your hearing is your STARTER due to the weak battery.
     
  7. maksym_3

    maksym_3 Junior Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Feb 2, 2006
    Hey, alright well im stumped, I got it to run by bump starting it with a tow, but when i turned the car off, it wouldn't start again

    I cleaned up my grounds, tried a different battery, and changed the starter.

    Now when i turn the key over, there is no sound, like the lights go on, every thing looks ok, but when i turn the key nothing happens.....


    Any help

    thanks
     
  8. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    make sure the grounds are good and also check to see if the starter is hooked all the way back up
     
  9. t3t4delsol

    t3t4delsol New Member

    Messages:
    652
    Likes Received:
    12
    Joined:
    Mar 18, 2008
    Location:
    York, Pa
    check your fuses under the hood, in the black box to see if you blew the master relay
     
  10. LS_VTEC

    LS_VTEC you get the BRAKE

    Messages:
    2,616
    Likes Received:
    25
    Joined:
    Dec 11, 2007
    Location:
    NJ
    Who installed the starter? And why? If it started up before than your starter is fine, just not enough amperage to turn it over. A new battery is all you needed.
     
  11. HondaElite

    HondaElite senior member

    Messages:
    135
    Likes Received:
    1
    Joined:
    Nov 2, 2006
    Location:
    fall river.mass
    ground the starter....
     
Verification:
Draft saved Draft deleted

Share This Page