1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GSR EG problems/build PLEASE READ :D

Discussion in 'Engine Building' started by gearbanger07, Jan 24, 2011.

  1. gearbanger07

    gearbanger07 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jan 24, 2011
    I just typed this post once, then firefox crashed, and now here we are.

    Anywhoo- I have a 93 EG Hatchback with an OBD1 GSR swap in it.
    heres a link to teh car
    Pictures by gearbanger07 - Photobucket

    As far as I know, and can see, here is what is done to it-

    *aftermarkeyt intake manifold (not sure on brand, as it has no stamps or logos)
    *4-1 headers high flow cat and 2.75in cat-back
    *CAI routed out of the front bumper, (on the passenger side it has a port in the bumper) its a KnM "whale penis" with the in-tube-paper/cloth filter
    *MSD Blaster 2
    *MSD Multi-ignition box (not hooked up)
    All of these things are the bolt-ons that I can remember
    I also have no idea if i have internal work or not.

    So, heres my bad-
    *leak in head gasket, right above the motor code stamp on the block, not exchanging fluids, just seepage from the block/head
    *there is a hiccup in 5-6k rpm that its going "baahhhhhh bap! bahhhhh" (yes yes i know, just bare with me...) but this is hard to diagnose becauuseeee-
    *It is not running a GSR ECU, somehow it is running off a SOHC D series ECU ( thats how the car came into my driveway, and i am not driving it in the winter so i have not changed it yet.)
    *It sounds like a subaru- this is not all bad. I absolutely love the sound of this thing. But i have read that this is a tall tale sign of a dead cylinder- but it runs too good, and too strong (other than that occasional hiccup i mentioned)
    *I replaced the plugs in it a few weeks before it went into hibernation and found the 2nd cylinders plug had been burning a different color than brown like the rest. (im thinking the whole thing is running rich-wrong ecu, and the back of its covered in black carbon deposit, and consider were counting the cylinder as 1 2 3 4 from tranny side to timing belt side)
    *vtech sometimes falls out in 3rd gear? like it pops, but you can hear it shut off? (And becasue i have that ecu problem to fix yet, this is pending along with the rest of my problems.)
    the good
    *runs good and strong (considering my ecu, and other minor issues im having)
    and thats about all i feel like ttyin to type

    i really would like to know some things to do on band-for-buck on n/a build
    and dont tell me to boost, i dont have that much money and id like to keep it running and not a grenade as lon as humanly possible

    anyways thanks alot hope to hear from you all sooon
     
  2. hondafreak513

    hondafreak513 New Member

    Messages:
    2,053
    Likes Received:
    46
    Joined:
    Nov 9, 2010
    Location:
    O hi O
    First of all get the right ecu p72... Second the spark plugs go the other way 4-3-2-1...1 being closest to the timing belt... And they should look like this on the dizzy.. images.jpg

    Get that fixed then if it still has a problem come back and let us know..
     
  3. gearbanger07

    gearbanger07 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jan 24, 2011
    I was just referencing the plugs. Not saying thats the actual order. Well, iim really having a tough time finding one... nobody around here has a p72 or anything i can chip.
     
  4. hondafreak513

    hondafreak513 New Member

    Messages:
    2,053
    Likes Received:
    46
    Joined:
    Nov 9, 2010
    Location:
    O hi O
    You can chip any ecu you want for obd1.. You can use a p05, p06, p28 and so on... As long as the ecu is obd1... So just get the one thats in it and get it chipped..
     
  5. boostin4fun

    boostin4fun Boosted ls/vtec ohh yeah!

    Messages:
    861
    Likes Received:
    10
    Joined:
    Jun 22, 2006
    Location:
    Omaha
    www.hmotorsonline.com can sell you a jdm p72 for $200. I would give them a call. I wouldnt even be running that car hard with the wrong ecu in it. You know it cant being doing anything good for the health of the motor; probably running it lean.
     
Verification:
Draft saved Draft deleted

Share This Page