1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

gsr running bad

Discussion in 'HYBRID -> EG-EK / DC' started by crxjoe, Jan 4, 2007.

  1. crxjoe

    crxjoe New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Dec 17, 2006
    Location:
    meredith n.h
    yo i need some help. my 94 gsr is running bad its revs from 1000rpm to 3000rpm just idleing an it has a tramendous loss of power. and wont rev high. pleze help me out
     
  2. tunedhonda-ata

    tunedhonda-ata im turbo bitch!!!!

    Messages:
    175
    Likes Received:
    0
    Joined:
    Aug 29, 2006
    Location:
    D-town
    did you just swap it or has it been in the car for a while?
    if you swapped it is it kicking a code?
     
  3. JDM_EK9R

    JDM_EK9R all motor

    Messages:
    81
    Likes Received:
    1
    Joined:
    Nov 4, 2006
    Location:
    central, NJ
    check your distributor, cap and rotor. as well as the plugs and wires. replace all and make sure your running the right dizzy for your motor/ecu. most likely its something stupid, vacuum leaks, wiring issues. take it to a tuner if all else fails.
     
  4. JDM_EK9R

    JDM_EK9R all motor

    Messages:
    81
    Likes Received:
    1
    Joined:
    Nov 4, 2006
    Location:
    central, NJ
    oh yea, timing could be the issue as well.
     
  5. tunedhonda-ata

    tunedhonda-ata im turbo bitch!!!!

    Messages:
    175
    Likes Received:
    0
    Joined:
    Aug 29, 2006
    Location:
    D-town
    it could be alot of things, but i would also say check vacume lines.. maybe check where your iac valve is make sure you have the write plug on it..
     
Verification:
Draft saved Draft deleted

Share This Page