1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

h22 vtec/rev problems

Discussion in 'HYBRID -> EG-EK / DC' started by H22aEj, May 16, 2011.

  1. H22aEj

    H22aEj New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    May 16, 2011
    ok..so ive looked for hours and days on the net and have come to a few conclusions...first off i have a ej1 w/ a h22a swap..and a s100p28..everythings been fine for the last couple months..all of a sudden today i got to drive..(after it was at optimum temp) and it wouldnt rev above 3k it was like hitting a limiter..i turn the car off then and on and it was ok..as soon as it cracked vtec it forced me down below 3k again and wouldnt go higher all afternoon its been coming ang going..one possibility i thought was tps but that was ok..now the car did have no2 and were the tps control spliced into the harness is still cut and corroded a little..idk if this is it..idk if my vtec solenoid is going bad..but my ecu was also making a buzzing sound when it would act up..or is a headgasket a possibility..it has no CELs a flash occaisianlly but thats frome the deleted o2..any help would be great..im hopin its nuthing to extreme like bad oil pump..car has normal h22/vtec smoke..no white smoke..no coolant in oil and temp stays were it should..plz help this is my baby...:confused:
     
  2. H22aEj

    H22aEj New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    May 16, 2011
    Bump
     
  3. H22aEj

    H22aEj New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    May 16, 2011
    please somone!!!!!
     
Verification:
Draft saved Draft deleted

Share This Page