1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

H22a 96 Civic Dx Hatch problems

Discussion in 'HYBRID -> EG-EK / DC' started by fondyboi, Jul 28, 2009.

  1. fondyboi

    fondyboi New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Jul 28, 2009
    Location:
    Wisconsin
    I'm recently getting a few problems with my H22A swap into 96 civic Dx hatch.
    1. The radiator fan is not working.
    2. Radiator hose are getting really hot quick. the bottom hose seem to be not getting any coolant at all, just empty and very hot. My coolant in the coolant tank is boiling.
    3. When I drive around, at 3k to 5k rpm, it seems to be very slow, then it'll just pick up and go.
    4. Engine seem to be overheating alot. It has gone to the 2nd mark past the middle one

    I've replace the waterpump, and the thermostate. I've run out of ideas and options. I dont want to keep replacing parts and not finding the cause. A few friends of mine has suggested to replace the whole radiator unit. I've been thinking if it will be possible to fit a bigger radiator.
    The car has some mods. AEM cold air intake, Complete MSD ignition system, AEM fuel rail and regulater and fuel injectors.
     
  2. 97h22dxcoupe

    97h22dxcoupe senior member

    Messages:
    332
    Likes Received:
    4
    Joined:
    Mar 29, 2009
    Location:
    Coffeyville, ks.
    yeah, use a dual core rad w/ thin fan (universal) make sure its a high output fan ,thats what i had to do with my h22 swap,if this helps rep me up...
     
  3. DESPAIN

    DESPAIN yep....mmhhm.......yep...

    Messages:
    1,703
    Likes Received:
    39
    Joined:
    Aug 1, 2008
    Location:
    flower mound TX
    that will most def. Fix your problem. Rep him......
     
  4. fondyboi

    fondyboi New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Jul 28, 2009
    Location:
    Wisconsin
    Thanks. I'm waiting for one I ordered to get here and see how it runs. I'll come back and rep you if it works out. But does anyone still know why the bottom radiator hose is really hot, but it seems to be empty? If i can just fix the heating issue, i'll be able to run it at the track. this has really put a damper on my summer driving.
     
  5. 97h22dxcoupe

    97h22dxcoupe senior member

    Messages:
    332
    Likes Received:
    4
    Joined:
    Mar 29, 2009
    Location:
    Coffeyville, ks.
    sounds like a thermostat issue, just swap out thermostat for new,becuz looks like your thermostat is closed off and not opening up......
     
  6. DESPAIN

    DESPAIN yep....mmhhm.......yep...

    Messages:
    1,703
    Likes Received:
    39
    Joined:
    Aug 1, 2008
    Location:
    flower mound TX
    how is the ol'h22 running?
     
  7. 97h22dxcoupe

    97h22dxcoupe senior member

    Messages:
    332
    Likes Received:
    4
    Joined:
    Mar 29, 2009
    Location:
    Coffeyville, ks.
    97h22dxcoupe

    its running good,got that bracket yesterday and put it on now i took it out on the road and it kicks ass ,but still need to adjust my injector issues ,but once it warms up it halls ass....:burnout:
     
Verification:
Draft saved Draft deleted

Share This Page