1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

h22a turbo trouble shooting

Discussion in 'Forced Induction' started by lilpaintballer10, Mar 10, 2012.

  1. lilpaintballer10

    lilpaintballer10 New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Jul 30, 2011
    Location:
    ohio
    i have a 92 civic eg hatch with a turbo h22a in it. i have three problems which im pretty sure are interconnected. first off, my boost controller doesnt seem to be working at all therefore my bov and my gauge arent working. how can i test to see if my boost controller is working corrected.

    also how should i have my vacuum / boost lines and my boost controller lines hooked up. ive been doing research on it but cant find concrete answers.

    any help would be awesome
     
  2. lilpaintballer10

    lilpaintballer10 New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Jul 30, 2011
    Location:
    ohio
    i had tried both of those setups and i adjusted my boost controller and it is still not working properly. the boost controller is a turbonetics mbc.
     
  3. lilpaintballer10

    lilpaintballer10 New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Jul 30, 2011
    Location:
    ohio
    well. i adjusted the boost controller as instructed, and my bov wouldnt go off, and my gauge had no readings. i played with all the adjustments on the boost controller and still nothing. i even tried just running a hose from the turbo housing to the wastegate directly (bypassing the boost controller) to see if my boost controller was the culprit and still nothing. ive tried adjusting my bov all the way to the softest setting and it still isnt going off. ive even changed my vacuum location several times and still no luck at all.

    i might end up throwing a brick through the winshield.
     
  4. lilpaintballer10

    lilpaintballer10 New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Jul 30, 2011
    Location:
    ohio
    we just checked to see if we were getting any boost and my wastegate isnt opening at all. the waste gate only has an 8 psi spring. would getting a vacuum manifold help produce enough vacuum to help it open or no?
     
  5. lilpaintballer10

    lilpaintballer10 New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Jul 30, 2011
    Location:
    ohio
    the wategate wont open at all. we tested the vacuum needed to assist the spring in opening and it was between 15-18inHg to see a noticeable movement in the valve. is that normal for an 8 psi spring?
     
  6. redxcobrax

    redxcobrax God member

    Messages:
    92
    Likes Received:
    4
    Joined:
    Nov 5, 2008
    Location:
    Kenosha, WI
    simply worded, when you floor it thru any gear do you actually feel the turbo spool up or hear it and can you feel the power difference? If not, then it might not be your boost controller. If you are POSITIVE that the waste gate flange/valve is closed, and you still are not getting boost, there is a leak somewhere, if it is open, then obviously all of your "boost" is escaping.
     
  7. lilpaintballer10

    lilpaintballer10 New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Jul 30, 2011
    Location:
    ohio
    yes, i took off the intercooler pipe leaving the turbo and i can feel the increase in air movement as you open the throttle.
     
  8. redxcobrax

    redxcobrax God member

    Messages:
    92
    Likes Received:
    4
    Joined:
    Nov 5, 2008
    Location:
    Kenosha, WI
    youll feel an increase in air movement regardless, but there is no pressure in the tubing that way. You may be getting an increase in airflow but not necessarily be holding boost, there may be a leak somewhere, or within the turbo itself. when you DRIVE can you feel the boost at all?
     
  9. lilpaintballer10

    lilpaintballer10 New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Jul 30, 2011
    Location:
    ohio
    havent gotten the chance to drive the car. i have another project on the car that im working on as well. could the turbo seal be bad?
     
  10. lilpaintballer10

    lilpaintballer10 New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Jul 30, 2011
    Location:
    ohio
    would T'ing into the brake booster hooking up my boost gauge, bov help. ive also heard that its not good to have your wastegate hooked up to vacuum as it can damage the diaphragm. any explanations and clarifications would be awesome.
     
  11. lilpaintballer10

    lilpaintballer10 New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Jul 30, 2011
    Location:
    ohio
    thanks for all your help! ill give it a shot this coming weekend as im in college the whole week.
     
Verification:
Draft saved Draft deleted

Share This Page