1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

h23a1-h22a swap no start

Discussion in 'Prelude' started by powerfox66, Oct 30, 2011.

  1. powerfox66

    powerfox66 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Oct 29, 2011
    a good friend had his h23a1 pulled and installed a h22a. the guy that did it cant get it to start.
    What I do know is this..they swapped oil pump and put a new crank/tdc sensors in front of motor...they got spark, will start and run if spray in throttle body. noid lite test injectors very intermittent flashing. so it seems to me we got spark and timing is ok.. i am in process of removing a very poorly installed viper alarm(twisted wires and little bits of electrical tape) and getting the harness back to a more stock condition.
     
  2. Matts96HB

    Matts96HB . Moderator VIP

    Messages:
    6,482
    Likes Received:
    390
    Joined:
    Apr 16, 2006
    Verify that there is spark one more time. It sounds to me like you have an issue with fuel. Was any of the wiring tampered with for the injectors?
     
  3. The Godfather

    The Godfather New Member

    Messages:
    53
    Likes Received:
    0
    Joined:
    Nov 1, 2011
    maybe a crimped fuel line? def sounds like a fuel issue if it runs with spray
     
  4. powerfox66

    powerfox66 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Oct 29, 2011
    thanks i know i can hear the pump run but didn't pressure check @rail..but would that effect the injectors not firing consistently
     
  5. powerfox66

    powerfox66 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Oct 29, 2011
    What sensors does ecm need to see for injectors?? 2001 prelude
     
  6. powerfox66

    powerfox66 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Oct 29, 2011
    viper alarm removed, and added 2 additional grounds from battery to engine & 2 more from engine to body..very intermittent injector pulse when using a noid lite...original harness, distributor, external coil, oil pump & a new tdc sensor from advance auto...they used injectors and intake from new motor, and motor did not have a ecu with it, so original ecu as well
     
  7. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,417
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    Original Non-VTEC ECU is what you are using?

    If starter fluid works then I agree that there's spark. If noid light gives intermittent reading then the ECU is sending a signal for the injectors to fire.

    I say its something with fuel not being delivered. Maybe smell the spark plugs after you crank it over a few times and see if you smell gas.

    Can you look into a correct ECU for the motor? Maybe its a start up issue (although I am skeptical that its the problem)
     
  8. powerfox66

    powerfox66 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Oct 29, 2011
    also checked grounds at ecu, and grounded ecu itself as well.. injectors measured 11.2 ohms from what i have read is high impedance injectors which should be used on the original 01 lude??
     
  9. powerfox66

    powerfox66 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Oct 29, 2011
    yes it is the ecu for the car...he did not get an ecu with new motor
     
  10. powerfox66

    powerfox66 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Oct 29, 2011
    The ECU that came with the car is a p5p so if i understand correctly, that ecu should also work with new motor??
     
  11. serrilion

    serrilion In my own little world! VIP

    Messages:
    1,758
    Likes Received:
    42
    Joined:
    Aug 13, 2007
    Location:
    Vermont
    Hold the phone. H23a1 was only found in the 4th gen preludes, So if ya freind has a 5th gen lude, and it had an h23a1 swap, that means he proably had it converted to OBD1 vs OBD2 that would cause a problem if you swaped an OBD2 h22 in the car. So what chasie does he have? 4th gen 92-96 or 97-01... this makes a hudge diffrance as if he has a 4th gen body and a 5th gen motor, the dizzy, ecu and fuel injectors would need to be switched out along with the TB
     
  12. powerfox66

    powerfox66 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Oct 29, 2011
    I think I have a bad crank/tdc sensor, I believe there should be some resistance measuring between both terminals thru the sensor(I am showing open on both),pin 1(green) to pin 2(red) for tdc & pin 3(blue) to pin 4(white) for crank. but due to my lack of experience with imports I am not sure. as stated above someone else put in a brand new(advance auto) ckp/tdc sensor
     
Verification:
Draft saved Draft deleted

Share This Page