1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hazards Not Working

Discussion in 'ECU's, Electronics, and Tuning' started by dveit, Jul 11, 2008.

  1. dveit

    dveit Well-Known Member VIP

    Messages:
    5,361
    Likes Received:
    79
    Joined:
    May 5, 2003
    Location:
    DMV
    So I've finally been around to work on some of the minor things on my car and I'm come across something simple that is just stumping me.

    For some reason the hazards on my car do not work. Both left and right turn signals work, but when I push in the hazard button... nothing. Since both my signals work I concluded that its not the bulbs or the fuses, but I double checked them anyways and they are fine. So I went to advanced auto and bought a turn signal/hazard flasher relay because I know those are common to go out. I replaced that and still the same thing, both left and right flashers work and the hazards nothing.

    I'm thinking that there must be something wrong with connections itself behind the hazard button. I just wanted to know if anyone had any other ideas or theories before I start to take the dash off.

    Anyone?
     
  2. Aleaf.CRX

    Aleaf.CRX Hates Cunts!

    Messages:
    2,025
    Likes Received:
    45
    Joined:
    Jan 22, 2008
    Well, this is not likely, but mine take like a minute to kick on. Maybe yours are the same?
     
  3. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    no idea..rip the dash apart time
     
  4. BrutalB83

    BrutalB83 Brutal Moderator Moderator VIP

    Messages:
    11,620
    Likes Received:
    302
    Joined:
    Jun 24, 2006
    Location:
    Rochester Hills, MI
    On my Accord and on my Integra, you could pop that button out without taking the dash apart. I'd do that first and make sure it's plugged in tightly...
     
  5. awptickes

    awptickes unimpressed by you VIP

    Messages:
    9,278
    Likes Received:
    498
    Joined:
    Aug 29, 2007
    Location:
    MD
    Sounds like it's the button to me. Try hitting it firmly.
     
  6. dveit

    dveit Well-Known Member VIP

    Messages:
    5,361
    Likes Received:
    79
    Joined:
    May 5, 2003
    Location:
    DMV
    How did you pop it off? Just use a flathead screw driver or butter knife or something? I'm not tyring to break things or scuff things up...
     
  7. CRX-YEM

    CRX-YEM Super Moderator Moderator VIP

    Messages:
    4,623
    Likes Received:
    54
    Joined:
    Sep 29, 2002
    Location:
    Wallingford, CT
    is there a relay for the hazards, either that or I'd check the acuall switch/button
     
  8. dveit

    dveit Well-Known Member VIP

    Messages:
    5,361
    Likes Received:
    79
    Joined:
    May 5, 2003
    Location:
    DMV
    yes there is a single relay for both the turn signals and the hazard lights. the relay is good, i tried switching it with a new one, no go...

    however, it wasn't a honda OEM, just one that I got from advanced auto.
     
    Last edited: Jul 24, 2008
  9. dveit

    dveit Well-Known Member VIP

    Messages:
    5,361
    Likes Received:
    79
    Joined:
    May 5, 2003
    Location:
    DMV
    Update: I took the center dash peice off and played with the hazard switch and still nothing.

    Now when the I push the hazard button in only the left turn signal blinks, and its very sensitive, like for example, if I push the button to the right a little none of the lights come on yet when I put pressure on it to the left only the left signal comes on.

    Bah. All I want is my fuckin hazards.
     
  10. nootrac22

    nootrac22 Well-Known Member VIP

    Messages:
    4,331
    Likes Received:
    131
    Joined:
    Mar 16, 2007
    Location:
    exeter pa
    sounds like it's the button. check the wiring to it or just buy a new one.
     
  11. awptickes

    awptickes unimpressed by you VIP

    Messages:
    9,278
    Likes Received:
    498
    Joined:
    Aug 29, 2007
    Location:
    MD

    I'm sure it's the button now.
     
  12. dveit

    dveit Well-Known Member VIP

    Messages:
    5,361
    Likes Received:
    79
    Joined:
    May 5, 2003
    Location:
    DMV
    Update: for those who care.

    After a while not only the hazards went out but the turn signals themselves starting acting up, sometimes blinking only a few seconds, sometimes completely going out altogether.

    So I pulled up my service manual and looked at the wiring diagram to find some things common to the two. Two main things: turn/hazard relay (located in the under-dash fuse box, which I already tried replacing), and the hazard switch (located behind the center console).

    I ordered a Honda OEM hazard switch and replaced it with no success, still everything acting up.

    I then ordered a turn/hazard relay from Honda and replaced it and everything works! For those with similar problems as mine, make sure you order Honda OEM products! The standard general turn/hazrd relay from Advanced Auto did not work even though it had the same volts/amps and connection.

    Problem fixed :)
     
Verification:
Draft saved Draft deleted

Share This Page