1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help...B18B Swap Problems

Discussion in 'HYBRID -> EG-EK / DC' started by vxn12, Sep 6, 2004.

  1. vxn12

    vxn12 Junior Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    May 27, 2004
    Hi,

    I am swapping a B18B out of an 01 integra into a '94 Del Sol. Got almost everything bolted-in, except for the shift linkage. The linkage that came out of the 01 integra is about an inch shorter than what I need. Can someone confirm this? I have been told that the B18B shift linkage should work in my car, but it's not. Any suggestion on a fix? I was thinking about having someone (a welder) extend it. Good idea? Is there a shift linkage that would work in my car? How much would it cost?

    Another problem that I have is the vacuum hoses coming out of the Charcoal Canister. On the D16Z, There are two hoses that come out of the canister and plug into the intake manifold. On the B18, I find that there is only one vac. hose input (located on top of the intake manifold), and it's a larger opening than any of the two hoses I have. The opeing is for some sort of sensor. I don't know what it is. I know for sure that it's not the MAP sensor. When I start the car, it seems like it's sputtering. When I put my finger to plug the the larger opening it helps a little (lowers the RPM too). What should I do?

    Thanks in advance!
     
  2. vtec84lude

    vtec84lude Junior Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Sep 6, 2004
    Location:
    Washington DC
    The shift linkage will work. You must have the wrong mount combo or need to look at it again.

    The canisters are different. You need to bypass the delsol one and plug the vacuum port on the manifold. You dont need the canister hooked up.
     
  3. vxn12

    vxn12 Junior Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    May 27, 2004
    I read somewhere that the B18b shift linkage will not work on a del sol, I guess I need get a Del sol Vtec shift linkage.

    As for the vacuum hoses, how do you bypass the canister? I have 2 hoses that suppose to plug in the intake manifold on the D16, but I can't find where they should go on the intake manifold of the B18. Do I just block them up? What about the vacuum hose on the B18? What should I do with it?
     
  4. puffy00

    puffy00 Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Feb 11, 2003
    the linkage will not fit on a del sol you need del sol dohc linkage i had that problem on my boys car but you could also weld it it works fine
     
  5. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    yup- teg linkages wont work. need del sol vtec linkage.

    a vacuum leak will casuse a rough idel and stalling.

    looks like your missing a sensor. take a pic.
     
  6. xj0hnx

    xj0hnx I wanna be sedated VIP

    Messages:
    14,172
    Likes Received:
    48
    Joined:
    Nov 10, 2002
    Location:
    C.C.TX.
    Just to reinforce...

    Only Del Sol B series linkage can be used on Del Sol B series swaps.
     
  7. vxn12

    vxn12 Junior Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    May 27, 2004
    Thanks for the replies. I have taken some measurements of what needs to be done to make the integra linkage work. It looks like the teg linkage needs to be lengthen by 1.5" (on both rods) and bent down about 1.25" on one rod and 2.25" on the other rod. I think this will work. I'm asking a friend to fabricate it for me. Will update you later.

    As for the hesitation, the problem is that on the B18B, there is only one vacuum hose that goes from the Purge Solenoid valve to the charcoal canister. On my del sol, the charcoal canister has two vacuum hoses on it. Both of these hoses are smaller than the one on the B18. I went out and bought a universal "T" to tie all of the hoses together to connect to the Purge Solenoid Valve. It didn't work for some reason. I then disconnected everything and tie one of the line from going straight from purge valve to the charcoal canister and I plugged up the other open hose. That helped a whole lot. Seem like the idle stabilized a whole lot. However, every 30 seconds or so, I hear the idle fluctuates a little, then come back up. But it's not hesistating anymore. I'm thinking about buying a charcoal canister from a 96+ integra to see if it helps even more. It costs only $25 at a salvage yard. What do you think?

    I'm trying to work on another issue right now, I think my speedometer and tachometer is switched up somehow with the new ECU. My old D16Z uses a P28 and I'm using an OBD1 P75 ECU with this swap. I don't know if the ECU pinouts are swapped for the speedo and tach. When I start up the car, which is on jackstand, the speedometer goes up to 20 MPH and the tach is on 0 RPM. When I rev up the engine, the speedometer goes up. That's why it think maybe the speedo and tach signals are crossed. I can't drive the car to know that the tach is working or not. Any ideas? Thanks again.
     
Verification:
Draft saved Draft deleted

Share This Page