1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

help car problem ASAP!!!

Discussion in 'Civic and del Sol - EG and EK' started by rkwoos12, Feb 12, 2009.

  1. rkwoos12

    rkwoos12 New Member

    Messages:
    353
    Likes Received:
    2
    Joined:
    Oct 28, 2008
    Location:
    Kentucky
    ok guys i have a new problem let me know what you think, i have a 94 civic ex and lately it started lossin power at 2k rpms to 3500rpms if i keep it below 2k rpms it runs fine but if i give it gass past 2000 it seems to lose power but if i let off the gas and play with the gas a little i can get it past 3500 rpms it will run fine then too, i have no engine light or nothing. so i dont know what it is let me know what you think it could be.
     
  2. serrilion

    serrilion In my own little world! VIP

    Messages:
    1,758
    Likes Received:
    42
    Joined:
    Aug 13, 2007
    Location:
    Vermont
    Have u checked fluid levels, also vacum lines?? I mite also check you fuel Filter, sometimes they get very clogged up and make the car run like crap around that rpm range
     
  3. rkwoos12

    rkwoos12 New Member

    Messages:
    353
    Likes Received:
    2
    Joined:
    Oct 28, 2008
    Location:
    Kentucky
    All fluid levels are correct, vacum lines are hooked up correct, new fuel filter, could it possibly be a bad vtec solenoid or maybe a bad ecu would the car run if i had a fried ecu? also it only loses the power when cold it will straighten its self out when engine warms up.

     
  4. rkwoos12

    rkwoos12 New Member

    Messages:
    353
    Likes Received:
    2
    Joined:
    Oct 28, 2008
    Location:
    Kentucky
    Problem solved, i took my eacv or iacv off and the screen was very dirty so i cleand my whole eacv with throttle body cleaner and it solved my idle surging problem and fixed my loss of power.
     
Verification:
Draft saved Draft deleted

Share This Page