1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP!! No spark on the B16

Discussion in 'General Tech and Maintenance' started by Speedracer228, Mar 9, 2005.

  1. Speedracer228

    Speedracer228 ......

    Messages:
    1,610
    Likes Received:
    2
    Joined:
    Feb 25, 2004
    Well to start off the car has been running a little rough since i just picked it up, but it felt like bad gas from the car sitting for 6 months. Therefore i filled up with 93octane and let it run for about a half hour and then it started to sound like it was missing. So i pulled the plugs and they looked like i was actually running a little lean, so i replaced them. It then just died at a stop sign and i had to push it to my friends house (really fun). After trying to start it some more i pulled the plugs and there was plenty of fuel getting in but i then tested the plugs and wasnt getting any kind of spark.

    So i took the cap of the dizzy and it looked a little white inside of it and smelled like it was burning a little bit. Now how can i tell if its bad or how can i clean it and try it again? Or could it be someting else?

    (the car is a 90 civic si with a B16 OBD-0)
     
  2. Speedracer228

    Speedracer228 ......

    Messages:
    1,610
    Likes Received:
    2
    Joined:
    Feb 25, 2004
    Anyone? I want to hopefully be able to figure this out after i get out of work today.......
     
  3. Speedracer228

    Speedracer228 ......

    Messages:
    1,610
    Likes Received:
    2
    Joined:
    Feb 25, 2004
    Bump for my lunch break

    I guess ill just order a new Dizzy from streetimports.com or get a used one from hmotorsonline, but if someone thinks it could be something else let me know ASAP i need to get this car running again!
     
  4. Speedracer228

    Speedracer228 ......

    Messages:
    1,610
    Likes Received:
    2
    Joined:
    Feb 25, 2004
    the dizzy on the car is deffianlty fried, and it appears to be the wrong one. The stamp on it says TC-05A when it should be TD-22U for the B16a1.

    I looked in the reference section and i cant even find where that came from, someone help me out here...
     
  5. IT-R Coupe

    IT-R Coupe Junior Member

    Messages:
    24
    Likes Received:
    0
    Joined:
    Dec 8, 2004

    i had the same problem with my b18c and i replaced the distributor and it fixed the problem. go to locashracing.com for one. there pretty cheat there and there new.
     
  6. Speedracer228

    Speedracer228 ......

    Messages:
    1,610
    Likes Received:
    2
    Joined:
    Feb 25, 2004
    yeah i just picked one up from streetimports.com 189 w/3 year warrenty. Overnighted it too, im tired of not havin a car B)
     
  7. Speedracer228

    Speedracer228 ......

    Messages:
    1,610
    Likes Received:
    2
    Joined:
    Feb 25, 2004
    So i researched and it looks like the TC-05A came from the 88 civic awd wagon. Now how it got on my b16 i have no idea?
    But someone deserves a swift kick to the nuts :kick:
     
Verification:
Draft saved Draft deleted

Share This Page