1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

help urgent symtoms of steam in engine bay and smoke from exhaust

Discussion in 'General Tech and Maintenance' started by joker01, Jul 3, 2011.

  1. joker01

    joker01 Member

    Messages:
    206
    Likes Received:
    0
    Joined:
    Oct 6, 2010
    Location:
    caribbean, St.Lucia
    hey guys jus got my d15b to start in my concerto and when the cars warms up i see steam coming from the engine bay and when i rev it isee lots of smoke am not sure if is carbon build up because the car was sittin on my lawn for a year without starting and i got a d15b to swap in..so ifanyone can help me diagnose the prob i would b very gratefull
     
  2. joker01

    joker01 Member

    Messages:
    206
    Likes Received:
    0
    Joined:
    Oct 6, 2010
    Location:
    caribbean, St.Lucia
    aqnyone can help guys plzzzzz in a jam here
     
  3. Dagnasty EF

    Dagnasty EF New Member

    Messages:
    69
    Likes Received:
    3
    Joined:
    Jun 22, 2011
    Location:
    Kenosha, WI
    Steam is coolantrunning or just moisture an d crap built up on the motor from sitting so long. Look at all your coolant junctions. As for the smoke.... what color is it.

    How long did u let it run for. Look for coolant leaking somewhere

    More info please were not mind readers
     
  4. Taco15

    Taco15 I wear stretchy pants VIP

    Messages:
    6,998
    Likes Received:
    203
    Joined:
    Jan 11, 2005
    Location:
    Tallahassee Fl
    true dat.

    it may just be the oil residue and coolant burning off.....
     
  5. joker01

    joker01 Member

    Messages:
    206
    Likes Received:
    0
    Joined:
    Oct 6, 2010
    Location:
    caribbean, St.Lucia
    sorry guys...well i found out my water pump is leaking and the smoke is thick white or blue i was told to chk if was my valve seals cuz the engine was sitting down for like 10months until i swapped it into my concerto its a d15b non vtec and the longest i allowed it to run was for like 5mins cuz of mywater pump leak but am gettin my pump replaced real soon i will keep urll updated guys thnx much
     
Verification:
Draft saved Draft deleted

Share This Page