1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Here comes another wiring question... lets see if someone knows this&#

Discussion in 'HYBRID -> EG-EK / DC' started by roadracer321, May 31, 2006.

  1. roadracer321

    roadracer321 Member

    Messages:
    35
    Likes Received:
    0
    Joined:
    Oct 7, 2005
    Well, I have done A LOT of research on this for months and months, but I cannot figure this out now. I have saved a bunch of articles on here, including a really good by 92B16VX "How To Wire VTEC" , but it doesnt apply to me because of different color wires.

    So here is what I have going on. As you can see, I have the SiR-G motor going into a 92 Civic HB

    Supposively the VTEC wires are run from the cannon plugs to the ECU, but I dont know what colors they are? There are two colors that I found that dont go to the engine, but are run to the cannon plug. Those two colors are org/wht and org/blu. Anyone know what these are? The article I read said the VTEC wires were yellow with some stripe colors on there. I dont have them. The colors I have are:

    red/yel
    red/wht
    pink
    lt grn
    grn/wht
    yel/white (this continues to go to the engine)
    red/grn
    org/blu
    wht/yel
    org/blk
    org/wht

    I have both Haynes manuals for the 92 Civic and the 94+ Integra, but the colors are not accurate for the integra. I dont know if this is due to the fact that it is a JDM engine. I am having trouble finding the VTEC pressure plug, I believe this is suppose to be a blue and black wire? Well, I cant find it.

    The knock sensor is another question. When I took it apart, I noticed there was a silver braided wire attached to it that I just cut off. Was that important to my wiring, or do I just run that red/blu wire to the ECU?

    Next is the IAB sensor. What the hell does this plug into? Where does it go? I found the pinouts for this, I hope this is accurate. I am going to be using the OBD1 p72 ECU. Does this get run directly to the ECU or to a cannon plug?

    Another thing, I have the Purge Control Solenoid and Electric Air Control Valve Solenoid. What do I do with these? I dont see these on my wiring diagram for the GSR motor.

    Thats all I can think of right now, all help with this would be greatly appriciated!!!

    I have looked all over for these answers before posting this.
     
  2. brokeHonda

    brokeHonda Junior Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Oct 5, 2005

    orange/blue is the oil pressure switch
    orange/white is the solenoid

    [​IMG]
     
  3. brokeHonda

    brokeHonda Junior Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Oct 5, 2005
    EG's were not wired for secondary butterflies. You're going to have to run a lead from the sensor to the ecu
     
  4. brokeHonda

    brokeHonda Junior Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Oct 5, 2005
    [​IMG]

    You should find your answers in this diagram.

    Pinouts for the p72 ecu (I believe):
    A20 for the PCS
    A9 for the IACV
    D3 for the KS
     
  5. roadracer321

    roadracer321 Member

    Messages:
    35
    Likes Received:
    0
    Joined:
    Oct 7, 2005
    Awesome!! Thanks a lot for the help! I can finally get this done, cause I was lost on these parts. You got all this from ProStreet? I didnt even know about that site.
     
  6. brokeHonda

    brokeHonda Junior Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Oct 5, 2005
    No problem!
    I didn't get the answers from prostreet. The images are psoted via we-todd who throws up the prostreet ad.
    All these diagrams are in the helms manuals. I sifted through the EG and the Gsr manual for the answers. I recommend you get the manuals!!!!
     
  7. roadracer321

    roadracer321 Member

    Messages:
    35
    Likes Received:
    0
    Joined:
    Oct 7, 2005
    I dont have a Valve Timing Oil Pressure Switch... Is this normal? I also looked on my harness for the B18C, and I didnt see one on there either. I called Hasport, and they said I have to put one in because the OBD2 engines didnt have one. Is there a way around this? The OBD1 P72 ECU requires that sensor to run.
     
Verification:
Draft saved Draft deleted

Share This Page