1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

High Nox

Discussion in 'Civic and del Sol - EG and EK' started by lint_rides_again, Sep 18, 2008.

  1. lint_rides_again

    lint_rides_again New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Mar 28, 2008
    I just failed emissions again.
    it reads CO2 13.4% O2 2.4% HC 95ppm CO 0.03% NO 3504ppm
    I have replaced the air filter, oil and filter, fuel filter, spark plugs, wires. non of witch made any difference. What would be my next move? I tried searching the forms first but didn't find an answer so sorry if I am asking what has been answered before.
     
  2. 99sidude

    99sidude Moderator Moderator VIP

    Messages:
    3,707
    Likes Received:
    170
    Joined:
    May 1, 2006
    Location:
    Ohio
    What mods if any are done to your car? Could be a bad o2 sensor.
     
  3. George777

    George777 ^^ Likes Bewbies

    Messages:
    2,917
    Likes Received:
    61
    Joined:
    Aug 17, 2005
    Location:
    With your mom
    Did you try playing with your ignition timing? I passed my emissions by doing that. Took a couple tries, but it finally passed.

    +1 on the O2...
     
  4. lint_rides_again

    lint_rides_again New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Mar 28, 2008
    No mods just a stock z6. I tried timing. Set at 14 deg. BTDC was the best but still way to high.
    the O2 sensor was replaced last year to get it to pass.
     
    Last edited: Sep 18, 2008
  5. lint_rides_again

    lint_rides_again New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Mar 28, 2008
    does a z6 have a EGR valve?
     
Verification:
Draft saved Draft deleted

Share This Page