1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

how do you guys feel about...

Discussion in 'HYBRID -> ED-EF / DA' started by rchondarepair, Jul 25, 2009.

  1. rchondarepair

    rchondarepair New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jul 24, 2009
    .... Ok so my 90 Integra with a JDM B16A cable swap is running rough.
    lacks power to the point where it is barely driveable.

    Getting plenty of fuel, plenty of compression, running rich.wasting gas. Dizzy and Ecu are fine. revs fine.

    I am thinking the grounds are suspect, as I know for absolute certainty only the lower Rad housing/ thermostat ground to be 100% good. This could cause my lack of power due to seemingly weak spark correct?

    I am gonna address this issue tomorrow morning. Please tell me this at least has a chance to fix the problem. I am getting desperate.
     
  2. Dark93DX

    Dark93DX New Member

    Messages:
    466
    Likes Received:
    2
    Joined:
    Apr 26, 2007
    Location:
    B.C.
    If an engine engine lacks power I would check, fuel, Compression (which you did) and spark, so yeah check that next.

    you may want to check your timing as well.
     
    Last edited: Jul 26, 2009
  3. DBCustoms

    DBCustoms New Member

    Messages:
    27
    Likes Received:
    1
    Joined:
    Mar 14, 2008
    timing should be the first thing checked. what computer are you running?
     
Verification:
Draft saved Draft deleted

Share This Page