1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

hunting idle / poor throttle response

Discussion in 'General Tech and Maintenance' started by michael_antoi, Feb 22, 2006.

  1. michael_antoi

    michael_antoi Member

    Messages:
    43
    Likes Received:
    0
    Joined:
    Sep 7, 2005
    few questions after my swap has been complete and almost running.



    Hunting idle. My breeze cluster has not tacho but my idle is really really up and down. There are a few things I read that it could be



    1. TB Gasket - Need to be replaced

    2. IM Gasket - is fine

    3. Ex. Man. Gasket - needs replacing

    4. Adjust Idle - How do I adjust my idle? I know where the screw is but which way do i turn it and by how much?

    5. Timing?? - WIll check with timing light

    6. Clean throttle body

    7. TB sensors - these are fine AFAIK.



    ANyone have any further ideas as to why the idle is hunting like crazy? and really loudly..





    Also. I find that my throttle response is terrible, to a point where my car stalls. At the moment it isn't drivable because of this but the idel would fluctuate so much that at times the car will have enough strength to go up and down my driveway hill and other times it wont make it and will stall.





    Why is my throttle response shithouse????



    Any ideas would be heaps helpful.



    I will try a few of the things mentioned and get back with the results.


    ENGINE IS D15B VTEC

    CONVERSION WAS CARB TO EFI

    ECU IS P28
     
  2. Incagnito

    Incagnito New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Oct 22, 2007
    same with my GSR

    I am having similar issues with my gsr. i need to get my idle down. and am having no luck with the screw on the throttle body, in fact i have played with it to the point all i can smell is the car running rich. what way do i turn it to lean it up a bit. i will live with a 800 rpm idle.

    not always but sometimes the idle will surge from 1000rpm to 1500rpm. every 20 starts or so it might do it,



    can someone help.
     
  3. NickBeam

    NickBeam New Member

    Messages:
    145
    Likes Received:
    6
    Joined:
    Sep 21, 2007
    Location:
    Ky
    I had a GSR swap and had similar problems. I took it to autolab in louisville and they said two of my sensor plugs where reversed. Which in turn fried them both. So the sensor's had to be replaced and they had to be switched.
     
  4. Incagnito

    Incagnito New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Oct 22, 2007
    :ph34r:thanks for your reply. I played with the screw on the throttle body to the point im not sure where it should be. it seems like that screw is for something else, not your idle. now it looks like i am gonna just tackle the intake manifold missions. upgrade the fuel rail, fuel pressure reg. get a new tps for it and see if that helps.

    im going to play with that screw some more cuz it seemed that the surging went
    away. but at one point the car bogged right to shit :eek: when it started. so that screw is maybe not letting enough or too much air getting it to run lean or rich??? I am a swap newb correct me if im wrong please. looking for the answer to this. what does the screw do and where should it be lol. thanks for your replies.
    :cool:
     
  5. NickBeam

    NickBeam New Member

    Messages:
    145
    Likes Received:
    6
    Joined:
    Sep 21, 2007
    Location:
    Ky
    Well I tried to adjust mine and got nowhere. If I made it too low it wouldn't surge as bad but it would die. I eventually cranked it up enough to where it wouldn't die but it constantly went up to 1500 where the ecu cuts off gas. (that's why there's an idle surge). It sounds like sensor problems. Is it throwing any codes?
     
  6. riceburner89

    riceburner89 Banned

    Messages:
    91
    Likes Received:
    1
    Joined:
    Jun 16, 2007
    Location:
    santa clarita CA
    Idle screw....... (adjust)




    IAC (Idle Air Controll) (clean) if no results (replace)



    Lack of coolant...... (top her off)






    Air in your cooling system.. (bleed it by that little bleeder by the thermostat)



    if all else fails your fucked! jk. one of those shoudl doit. last i herd motors dont idle wierd cuz they feel like it. its something causing it to doit

    really can be your IAC. thats what im having problems with. gatta replace it
     
  7. Incagnito

    Incagnito New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Oct 22, 2007
    NickBeam -- Nah no engine codes are thrown currently.

    RiceBurner - Thanks for your help. I haven't checked the coolant levels. It is something I should look into. the car is used so who knows if the previous owner even put the right mixture of coolant, IAC is something else I havent checked.

    Thanks for your suggestions.
     
Verification:
Draft saved Draft deleted

Share This Page