1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I need help fixing my stock tachometer

Discussion in 'ECU's, Electronics, and Tuning' started by prelude power, Jun 30, 2003.

  1. prelude power

    prelude power Junior Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Mar 10, 2003
    Hey who ever can please help me Id appreciate it. I tried to put some indiglo gauges on my 99 prelude and now my dam tachometer and gas gauge doesnt work. I dont know I think I messed the needle up but if anybody can help me Id really be thankful.
     
  2. JDMilan

    JDMilan Senior Member

    Messages:
    6,730
    Likes Received:
    0
    Joined:
    May 11, 2003
    Location:
    Boca Raton, FL
    I had a similar problem when I ordered my SiRII cluster from the west coast, it came a little messed up. what I did is made sure all the screws were tightened down enough, and also made sure all connections were sodered together and or plugged in together. Just follow your footsteps backwards.



    Milan
     
  3. halcyon985

    halcyon985 Senior Member

    Messages:
    151
    Likes Received:
    0
    Joined:
    Jun 15, 2003
    Location:
    Philly PA
    Had a problem when I put my white faces in, my friend with a probe was like oh here you just slip the needles off, and he broke the one off. I had to just get a new guage, it was like 30 or 40 bucks.
     
  4. hcivic.com

    hcivic.com Senior Member

    Messages:
    4,571
    Likes Received:
    2
    Joined:
    Jan 7, 2003
    Location:
    Calgary Alberta canada
    ok tack the cluster apart and reinsert the needle into the plastic clip
    (you need to remove the guges from the pod to gat at the inside of each gauge
     
Verification:
Draft saved Draft deleted

Share This Page