1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ice damage?

Discussion in 'Civic and del Sol - EG and EK' started by Timmy o toole, Jan 23, 2011.

  1. Timmy o toole

    Timmy o toole New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Jan 15, 2010
    Didnt run my car for about 3 weeks during an icy spell and it wont start now, its getting spark but no fuel, i tried runnin a live to the pump and got fuel but still no start not even a splutter, tried changing the ecu and main relay no good cant find any blown fuses and the timing belt is fine.the last time it was ran it was perfect turned it off and no one was near until i tried it.its probably only something small but its got me baffled. i know the water pipes froze up but there was no damage after the thaw i know yer all sick of the my car wont start questions but any help is appriciated thanks
     
  2. Briansol

    Briansol Admins Admin VIP

    Messages:
    21,455
    Likes Received:
    2,117
    Joined:
    Nov 18, 2007
    Location:
    CT
    How cold is it? gas doesn't freeze until stupid sub-artic temps of like -100.

    but if you had water in the gas, it's a different story.

    I would suggest bringin it inside somewhere for a day (heated garage) and let the car thaw out.
     
  3. Timmy o toole

    Timmy o toole New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Jan 15, 2010
    its well thawed out by now but it was about -8c for 2 weeks. i didnt do a comp test yet but i doubt the block is cracked.
     
  4. TurboMirage

    TurboMirage YEEAAAHHH VIP

    Messages:
    24,580
    Likes Received:
    696
    Joined:
    May 20, 2003
    Location:
    Central, MA
    block heater? you really should have one for those temps.
     
Verification:
Draft saved Draft deleted

Share This Page