1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Idle issue is back !!!

Discussion in 'Civic and del Sol - EG and EK' started by mintoxik, Mar 29, 2009.

  1. mintoxik

    mintoxik Member

    Messages:
    430
    Likes Received:
    4
    Joined:
    Feb 22, 2008
    Location:
    Oceanside
    So a little while back I had the rpm issue I just messed with somethings and one day it worked but now it idles high and surges when warm.
    ok so at first it idle at 2k so I cleaned the iacv and it went down to about 1500. and in the warm up if I put a load on it the ac headlights it will drop
    and when its warm it surges form 1k to 2k.
     
  2. murray195

    murray195 Member

    Messages:
    112
    Likes Received:
    5
    Joined:
    Mar 2, 2009
    Location:
    Calgary, AB
    Whats your coolant level at? Have you bled the system? Any coolant leaks? I started to get a minor leak the other day, and thats exactly what my eg did.
     
  3. 91crxdxy8

    91crxdxy8 New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Mar 28, 2009
    two things you can check depending on what year civic you have at the bottom of the throttle body is the fast idel valve it speeds up rpm at cold temps then idels out once warm the other thing to check is the tps you check it it should have voltage around like.4 closed and 4.5 at wot
     
  4. Delsol94

    Delsol94 New Member

    Messages:
    242
    Likes Received:
    0
    Joined:
    Dec 17, 2008
    Location:
    Boonsboro Maryland
    had the same problem but mine threw the iacv code and swaped iacv's and adjusted the fast idle and now its fine
     
  5. Slow&Delirious

    Slow&Delirious isn't fast or furious

    Messages:
    548
    Likes Received:
    8
    Joined:
    Jul 7, 2008
    Location:
    Boonville NC
    what did you clean your IAC with?
    some cleaners can damage it, I had to replace mine a while back
     
Verification:
Draft saved Draft deleted

Share This Page