1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Innovative mount issues HELP

Discussion in 'HYBRID -> ED-EF / DA' started by EF9_boy, Apr 15, 2010.

  1. EF9_boy

    EF9_boy New Member

    Messages:
    323
    Likes Received:
    2
    Joined:
    Sep 23, 2008
    Location:
    TX
    i bought innovative mounts to swap a b20z into my ef the rear mount and trans mount are fine but im having issues with my driver side mount.


    on my b20 there are 2 threaded posts that are tapered at the bottom that my mount slides over

    the problem is my mount wont go over the tapered section so it wont sit flush and only 1 nut can be screwed on

    also when the mount is on the posts it sits at a serious angle...is this normal?
    (i remember some guy on here had the same angle issue i but couldnt find the thread)

    do i need to drill out the holes on my mount to make it slide over the tapered section?
     
  2. efhondakid

    efhondakid My name is Byron. VIP

    Messages:
    7,034
    Likes Received:
    202
    Joined:
    Mar 2, 2007
    Location:
    Akron-Canton, Ohio
    You need the mount on the block from a DA Integra.
     
  3. EF9_boy

    EF9_boy New Member

    Messages:
    323
    Likes Received:
    2
    Joined:
    Sep 23, 2008
    Location:
    TX
    aight thanks man:thumbsup:
     
  4. kelsodeez

    kelsodeez New Member

    Messages:
    833
    Likes Received:
    33
    Joined:
    Sep 24, 2009
    Location:
    bay area, CA
    yup. i had the same issue. you need the mounting bracket with one post and a hole. just go to the junkyard. i got one for 10 bucks.
     
  5. EF9_boy

    EF9_boy New Member

    Messages:
    323
    Likes Received:
    2
    Joined:
    Sep 23, 2008
    Location:
    TX
    i have a spare off a junk ls layin around my other house and about a thousand extra bolts lol

    thanks guys i was startin to get real worried/pissed for a min
     
Verification:
Draft saved Draft deleted

Share This Page