1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installed USDM p30 ECU, now erratic/bouncing idle

Discussion in 'HYBRID -> EG-EK / DC' started by Torqueless, Mar 30, 2010.

  1. Torqueless

    Torqueless New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Mar 25, 2010
    Hey all,
    I recently purchased a usdm p30-a00 ecu and my car has been idling erratically, and have been bouncing up and down between 500-1200.
    I checked out the iacv and fitv as well as the sensors and they seem to be fine.. so i replugged in my old ecu and the idling was back to normal.
    There were no ecu codes or anything...
    What could be the cause? I resetted the ecu a few times and i still get the bouncing idle. Any help? I need to get my car smogged tomorrow and i'm stuck :[
     
  2. Torqueless

    Torqueless New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Mar 25, 2010
    Sorry, My car is a 93 Si... and i just put in a b16a engine.
     
  3. Torqueless

    Torqueless New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Mar 25, 2010
    Ok, so I found that one of the spark plug wires have a crack in the boot... the symptoms fit the description of a misfire (bouncing idle, also my car has a hard time accelerating at certain rpms)... I'm getting wires tomorrow and hopefully this will remedy the situation..

    But the quesiton is, why would the old ecu work just fine?:confused:
     
  4. Briansol

    Briansol Admins Admin VIP

    Messages:
    21,453
    Likes Received:
    2,117
    Joined:
    Nov 18, 2007
    Location:
    CT
    is it throwing any codes? did you wire in the knock sensor?
     
  5. Torqueless

    Torqueless New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Mar 25, 2010
    yeah wired in a knock sensor/wire and no cel code...
     
  6. b18JDMcivic

    b18JDMcivic Junior Member

    Messages:
    42
    Likes Received:
    0
    Joined:
    Jul 19, 2006
    Have you checked your timing? That could be the problem. Sounds like the symptoms..
     
  7. Torqueless

    Torqueless New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Mar 25, 2010
    yeah checked timing too.. actually i redid the timing (set to 16) and everything else checked out ok..
     
  8. GlassHeadlights

    GlassHeadlights West West Yall

    Messages:
    4,066
    Likes Received:
    71
    Joined:
    Oct 24, 2007
    Location:
    Calgary, AB
    Bad wiring....broken or chipped ECU...
     
  9. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,416
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    JDM B16A????

    If so...I have the same set up (except my Si is a '92). I bought the same ECU and found out it was chipped. I made the guy exchange it (a recycler) for a good one. I would think that you have a faulty ECU if the JDM one works.....although....maybe....did you forget to purchase and hook up the Evap Purge Solenoid??? This question is only if it's a JDM motor b/c they do not have an Evap Purge Solenoid and the JDM ECU doesn't look for it....while your USDM ECU is looking for it.....although it should throw a code......weird.

    Can you get you $$ back on the ECU? Or exchange? I would try that.

    Are you sure you CEL bulb is still good? When you first turn you key to the "On" position...it should light up
     
  10. Torqueless

    Torqueless New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Mar 25, 2010
    yeah actually i did hook up the evap purge solenoid by routing a vacuum line from the intake manifold to the solenoid and no ecu code from that so i think it's ok..
    my guess is the ecu.. the guy said he would accept a return but he doesnt have another p30-a00 ecu...
    do you think i can pass smog with the jdm p30? Man this stress is killing me... i replaced the ignition wires and i still get the bouncing/erratic idle... :confused:
     
  11. Torqueless

    Torqueless New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Mar 25, 2010
    And yes the cel bulb is good because i get the light when i turn the car "on"
     
  12. Torqueless

    Torqueless New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Mar 25, 2010
    hmm your post got me thinking cafrog...
    do you think it could be the way i hooked up the evap purge solenoid? I used a t-fitting to route a vacuum line that goes from the pcv to the intake manifold so that it goes into the evap purge solenoid...
    but it idles just fine when i have the jdm p30.. it would give the same symptoms?
     
  13. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,416
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    I am confused on how you actually ran it

    the Evap Purge Solenoid......it comes out from the IM at the back near the ear tab on the drivers side (with a nipple on the end). You need to tap a fitting (with a nipple to accept a hose) into the manifold (or...I got a B16A3 IM and called it good) And then run a short rubber line that goes from the nipple in the IM to the evap purge (the robot looking thing lol) and out the evap purge to your charcoal canister. You shouldn't have tee-d off at the PCV at all. You should already have a long rubber line that goes from the charcoal canister to the robot dude. Try to plumb it that way and see if that fixes it. Makes sense b/c the JDM ECU isn't worried about that thing hooked up wrong or not.

    Try my way......I think it will fix it!!!
     
    Last edited: Mar 31, 2010
  14. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,416
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    And thats why you aren't throwing a code too.....try it!!
     
  15. Torqueless

    Torqueless New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Mar 25, 2010
    yeah i think you may be correct cafrog... i thought i had it done correctly but using a t-fitting might have caused the idling problem.. don't have time today but i'm fairly confident that will fix the problem. Thanks!
    Anyways.. once i'm done with the smog and it works out.... Anyone interested in a USDM P30 Ecu? :D
     
  16. cookiemonster

    cookiemonster New Member

    Messages:
    17
    Likes Received:
    0
    Joined:
    Apr 24, 2010
    hi i was wondering if you get it smog yet? i have a jdm b16a as well and would like to know
     
Verification:
Draft saved Draft deleted

Share This Page