1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

integra ls obd1 swap gsr obd 2

Discussion in 'Integra' started by integraGSRda, Nov 13, 2011.

  1. integraGSRda

    integraGSRda New Member

    Likes Received:
    Nov 12, 2011
    I just swap gsr motor into my stock 91integra ls. now as i get ready to crack my motor the car wont start. it cracks but somehow it wont start. if it do start it dies. I check the motor for fuel, spark, timing and its all good. But then the compression is low on three valve and one of the valve do not read anything its coming up as 0. Im stuck at finding why it wont start. can it be the piston rings are bad or what?
  2. custompainter

    custompainter drive it like U stole it

    Likes Received:
    Jan 16, 2007
    central CT
    you have bent valves you bought a bad motor .... more then likely the person from whom you bought your motor.. snapped the timing belt beating the crap out of it and all the valves slapped the pistons.. and then they sold it to you ....

    good way to tell is to remove a spark plug pore two cap fulls of oil down into the cylinder and do a compression test if the compression goes back up it's your rings if it stays the same it's the valves ... if in fact it is the valves your going to have to rebuild the top end not that bad the down side is your still not going to know if the rings are shot to because the valves being shot keep you from getting a good compression reading ... more then likely your going to do the top end and find when it's back to gether you just wasted a head gasket because the rings are shot too...... but you never know it just might be the valves and you might luck out.... i my case i didn't luck out and got stuck with a crap motor ..... GOOD LUCK...
Draft saved Draft deleted

Share This Page