1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

is it my stater?

Discussion in 'General Tech and Maintenance' started by team love, Aug 29, 2006.

  1. team love

    team love red vx (lookout)

    Messages:
    27
    Likes Received:
    0
    Joined:
    Jul 19, 2006
    Location:
    Auburn,Maine
    it slowly cranks over the more i pump excelerator it cranks faster and faster till it starts once it starts it smells like a bigg gressy egg fart i recently diconected fuel rail to clean injectors on my d15z1 any ideas fuel pump? styarter? ???????
     
  2. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    sound slike your battery isn't giving it enought juice.... swap your batter with a friend or your mom or something and see if it fixes the problem.
     
  3. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    i whole heartedly agree with b, sounds like a battery problem. might just need to clean the terminals and leads.

    mine was doing that the other day and the terminals were just a LITTLE (really) dirty. cleaned em off (after replacing the alternator didnt work) and voila, working car again.
     
  4. hybrid_b18

    hybrid_b18 crew chief

    Messages:
    254
    Likes Received:
    0
    Joined:
    Sep 24, 2003
    Location:
    Burnsville, MINNESNOWTA
    or try a volt meter to you battery. check for 12 volts.

    when the car is starting check for amps. about 400 +/-

    after the car is running, check for voltage. 14volts
     
Verification:
Draft saved Draft deleted

Share This Page