1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Is my engine dying?

Discussion in 'Forced Induction' started by jimboburgess, Nov 30, 2005.

  1. jimboburgess

    jimboburgess Go fast, Go Cheap

    Messages:
    1,341
    Likes Received:
    14
    Joined:
    May 7, 2005
    Location:
    nyc
    So everything was running fine.
    Now my boost gauge is only reading a -5 psi
    i know i am making boost because the engine acts the same as it did previous to my gauge reading wrong.
    so it my be my boost gauge is broken

    although the engine studders/misses when at WOT under boost
    i checked for intake/exhaust leaks and didn't find anything
    please tell me the turbo i have is crap and not that the engine is going.
     
  2. B16RacerN2NR

    B16RacerN2NR Working Hard VIP

    Messages:
    6,148
    Likes Received:
    99
    Joined:
    Feb 28, 2003
    Location:
    Moving back West...
    check your spark plugs. could be fouled out, loose, ect.... Start with the easy stuff first, don't always assume it's something big. start small and work your way up.

    you need to KISS the situation
     
  3. jimboburgess

    jimboburgess Go fast, Go Cheap

    Messages:
    1,341
    Likes Received:
    14
    Joined:
    May 7, 2005
    Location:
    nyc
    I had the thought that it could be the sparkplugs.
    I will try to put it new ones and wires and such too.
     
  4. phyregod

    phyregod !!YTINASNI

    Messages:
    9,449
    Likes Received:
    225
    Joined:
    Jun 11, 2005
    Location:
    Central Texas
    Compression check. That'll tell you if the motor is taking a shit.
     
  5. reckedracing

    reckedracing TTIWWOP VIP

    Messages:
    21,056
    Likes Received:
    1,180
    Joined:
    Dec 5, 2002
    Location:
    NY
    :werd:
    compression test is the easiest motor life checker...
    is it pinging/knocking?

    what sort of managment do you have?
     
  6. jimboburgess

    jimboburgess Go fast, Go Cheap

    Messages:
    1,341
    Likes Received:
    14
    Joined:
    May 7, 2005
    Location:
    nyc
    www.phearable.net burned my program, running with 450cc injectors.
    i am planning on getting it tuned after xmas.
     
  7. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    check for boost leaks in the piping... its common to loose a charge pipe...
     
  8. 92civicb18b1

    92civicb18b1 The Trisexual

    Messages:
    8,859
    Likes Received:
    18
    Joined:
    Oct 1, 2003
    Location:
    The asshole of the USA, New Jersey
    yea it is...I used to blow an IC pipe every other day until I got some decent clamps.

    But like the others said. Compression test and check for fouled plugs as well.
     
Verification:
Draft saved Draft deleted

Share This Page