1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I've got 94' gsr with mad hesitation

Discussion in 'General Tech and Maintenance' started by lambgsr1, Aug 17, 2003.

  1. lambgsr1

    lambgsr1 Junior Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jul 15, 2003
    :ph34r: I've got a 94' Integra GSR. I just changed out the distributor which I was told was bad by a mechanic. Since then my car runs like it's a civic 1.6. with two missing pistons. The weird thing is, that it doesn't do it constantly. Just every once in a while. What's up with that. I pretty sure it's the correct distributor and no codes are showing up. Oh yeah Humid days are a bitch!
     
  2. Havok

    Havok Senior Member

    Messages:
    6,827
    Likes Received:
    1
    Joined:
    Sep 28, 2002
    Location:
    Florida
    Hmm, it's kind of broad...any CEL codes, or anything else you can describe in detail. Are you sure you have the correct distrubtor?
     
  3. HatchSpeeD

    HatchSpeeD ...Hi...

    Messages:
    1,241
    Likes Received:
    0
    Joined:
    Apr 14, 2003
    Location:
    Beantown
    Does it do it mainly when its raining or when theres a lot of moisture in the air?
    If so, its most likely your ignition coil.
     
  4. hybridsol

    hybridsol Senior Member

    Messages:
    411
    Likes Received:
    0
    Joined:
    Oct 5, 2002
    Location:
    ohio
    adjust your timing
     
  5. chevy302dz

    chevy302dz Senior Member

    Messages:
    209
    Likes Received:
    0
    Joined:
    Oct 1, 2002
    double check the firing order and make sure all wires are seated, then adjust timing to spec it's probably to far advanced.
     
Verification:
Draft saved Draft deleted

Share This Page