1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

JDM B16A cranks no spark

Discussion in 'General Tech and Maintenance' started by Derrick P., May 15, 2015.

  1. Derrick P.

    Derrick P. New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    May 15, 2015
    Location:
    NC
    Kinda a newbie here but I have a JDM b16a obd1 it cranks but no spark.. I have new wires and new coil rotor and cap for my dizzy. Not sure if I should of but I have a corolla and I tried to use that battery to see if it was the battery and still nothing it was just cranking happening no spark. I'm thinking maybe the starter but don't know cause it cranks. I need help any advice?
     
  2. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,416
    Likes Received:
    152
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    Check all grounds. Should have a ground near thermostat, valve cover and transmission.

    Do you hear the fuel pump prime when you put the key to the "on" position? Or....after trying to get it to start, take a spark plug out to see if it is soaked in gas (may not be getting spark)
     
  3. Derrick P.

    Derrick P. New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    May 15, 2015
    Location:
    NC
    So I checked all my grounds.. They are good.. The one for the thermostat housing runs with all the other wires for the wore harness so I'm guessing its grounded in the cab but idk where.. And the fuel pump primes.. I sprayed starting fluid in the intake manifold and nothing
     
  4. Derrick P.

    Derrick P. New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    May 15, 2015
    Location:
    NC
    And it primes in the on position
     
  5. Briansol

    Briansol Admins Admin VIP

    Messages:
    21,452
    Likes Received:
    2,116
    Joined:
    Nov 18, 2007
    Location:
    CT
    Check your plug order... in fact, pull a wire and plug out, and arch it against the chassis while someone else turns the ignition to see if the plug is even firing. could be a bad distributor, or ignitor, or wiriing going to it.

    what ecu are you using?
     
  6. Derrick P.

    Derrick P. New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    May 15, 2015
    Location:
    NC
    So I checked the plugs and they are in the correct order... I have a tool that test for spark and it doesn't blink at all. So just to be safe I put it against the chassis as you said and still nothing. I'd like to hope the dizzy isn't bad cause its brand new. What do you mean by ignitor? And the wiring I'm not sure of its the wiring but the plugs are good and no loose ends on that part.. Its a jdm b16A Sirll in a 92 civic hatch with a obd1 p28 ecu.
     
  7. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,416
    Likes Received:
    152
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    No spark. It might be something silly. Double check all electrical connections...like someone else did it and you're checking their work.

    Can you try the ECU in another car to check it?

    Correct distributor for sure? Check that rotor is on correctly?
     
  8. Derrick P.

    Derrick P. New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    May 15, 2015
    Location:
    NC
    Unfortunately can't check the ecu, and the dizzy is the exact same brand and part number as the other one and the rotor is on correctly in the same spot as before.

    Is there a possibility its the starter? I know it sounds crazy..

    And I'll double check all the wiring from the dizzy to the ecu.
     
  9. Derrick P.

    Derrick P. New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    May 15, 2015
    Location:
    NC
    OK so I had pulled the starter and got it checked Nd as I figured it was good O'Reily checked it.. I reinstalled it.. Now the dang thing doesn't even crank.

    All wiring looks good FYI
     
  10. Briansol

    Briansol Admins Admin VIP

    Messages:
    21,452
    Likes Received:
    2,116
    Joined:
    Nov 18, 2007
    Location:
    CT
    The starter just turns the flywheel, it doesn't bring ignition over.

    check your fuse panel. It's possible you popped something
     
Verification:
Draft saved Draft deleted

Share This Page