1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

JDM B16A swap running crappy

Discussion in 'Civic and CRX - EF' started by FC3Sdrift, Aug 17, 2008.

  1. FC3Sdrift

    FC3Sdrift New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Aug 17, 2008
    I did a jdm B16a swap into my buddy's 91 CRX SI, it idles super low, like 200rpm and when you rev it up its good, but then when you let off it drops right low or stalls out, drivin it it goes good, it just idles like crap, i used his engine harness and added the pins to it for vtec,o2 and knocksensor


    I took off and cleaned the IACV, and switch to his old one
    cleaned all inside the IM with TB cleaner
    checked the TPS, and tried a different one
    changed the coolant sensor
    changed the sparkplug wires,and spark plugs
    changed tha map sensor
    unbolted the cat to see if it was clogged
    put the old ecu in
    tried turning the idle up, but has no huge effect
    still does it


    after changing all that it would idle decently sometimes until you rev it and let it drop back down and almost stall, and then it would sometimes go back to idling really low

    It has nice crisp throttle response, no hesitation, revs through the rpms nice and good, but bad fuel mileage .....its only at idle thats being the big problem ...If it was my car i would just drive it around for a week to see if it clears up but i guess its to hard for him to hold the rpms up a bit
    who knows how long the motor sat before, it was dirty as hell in the IM

    He got a spare distributor from his buddy to try and see if that makes a differance?
    other than that i'm running out of ideas
     
  2. 1sikef

    1sikef New Member

    Messages:
    105
    Likes Received:
    0
    Joined:
    Jul 22, 2008
    hmm... thats odd, it sounds like you did everything really, but after you change the dizzy let me know if it make a difference, and what ecu is he running and is it a virgin or chipped
     
  3. FC3Sdrift

    FC3Sdrift New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Aug 17, 2008
    its not chipped yet i was gonna burn him a spoon chip

    I think its my own stupidity, when he got it the TPS got smashed in shipping so i changed that out after, but i never cleared the codes lol......could the ecu just be stuck in limp mode from the old codes???

    how do you clear the codes on a honda?
     
  4. FC3Sdrift

    FC3Sdrift New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Aug 17, 2008
    still need some suggestions here?
     
  5. George777

    George777 ^^ Likes Bewbies

    Messages:
    2,917
    Likes Received:
    61
    Joined:
    Aug 17, 2005
    Location:
    With your mom
    Pull the fuse and let it sit for a few minutes and then put it back in.
     
  6. ccsgsr1

    ccsgsr1 Banned

    Messages:
    58
    Likes Received:
    2
    Joined:
    Jul 20, 2008
    Location:
    POCONOS
    could be vacum as well.
     
  7. FC3Sdrift

    FC3Sdrift New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Aug 17, 2008
    i listened and looked around for a vacuum leak and cant find any...could there be an old code kickin around causing issues?
     
Verification:
Draft saved Draft deleted

Share This Page