1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

JDM F22B DOHC swap. PLS HELP!!!!!

Discussion in 'Accord' started by 95LxCD5, May 11, 2009.

  1. 95LxCD5

    95LxCD5 New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    May 11, 2009
    i recently done a F22B DOHC non-Vtec swap into my accord bc i slung a rod in the original motor...well i been wanting to do this swap and the rod sling gave me a better reason to do it. [​IMG]

    anyway there is a problem when you drive it. When you first crank it up it sounds good, nothin wrong with the motor when you drive it until it gets to temp then thats when it feels like i lose power in 1st gear and completely lose 3rd. Its an Automatic.

    i think i may need to replace the tranny but idk. the CEL also pops on pullin the IACV code around the same time the tranny starts messing up. When you slow down at a redlight the motor about dies and starts revin between 1k and 2k quite fast.

    also i been thinking about putting a P14 ecu in it bc i read it controls the motor better than the stock one.

    any ideas on the problem?
     
  2. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,414
    Likes Received:
    150
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    The transmission is most likely reacting to the change going on when your idle air control valve is acting up.

    Change the valve or look into cleaning it first.

    I dont think its the AT by your description
     
  3. 95LxCD5

    95LxCD5 New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    May 11, 2009
    while test driving it today i noticed that the CEL wasnt even on and the RPMs werent even reving fast...not even at all, they were normal......but it felt like all i had was 2 gears. i had to do 55 in second gear bc it wouldnt even shift into 4th.

    its kind of random which gears dont work either, today it was 3rd and 4th and a few days ago it was 1st and 3rd. could it be the torque converter?

    one things for sure is the new motor pulls like a beast in 2nd gear. lol[​IMG]
     
  4. 92AccordJDM

    92AccordJDM New Member

    Messages:
    76
    Likes Received:
    0
    Joined:
    Sep 7, 2008
    Location:
    ct
    damn i wish i could help you out with this cause im doing this swap at the moment but i cant get the axle bolts off what year accord are you doing this swap in and i dont think the stock ecu would make it run that sluggish but i would definitely say work on getting a newer ecu. if you have the same year as i do then maybe i could come to you for some info and mine well be a auto as well but i got the tranny for the f22b with the motor.
     
  5. 95LxCD5

    95LxCD5 New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    May 11, 2009
    its a 95 Accord Lx
     
  6. 92AccordJDM

    92AccordJDM New Member

    Messages:
    76
    Likes Received:
    0
    Joined:
    Sep 7, 2008
    Location:
    ct
    hmm i maybe wrong but i dont think the ecus from the 94+ would run the car like the 90-93 do i mean they dont run the car as best as they could but i think the 90-93 ecus work better idk what type of ecu you have in yours? and have you checked all of your vaccum hoses among other things like egr valve , tps sensor....
     
  7. 95LxCD5

    95LxCD5 New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    May 11, 2009
    its the stock POJ ecu...i guess thats the ecu number...

    anyway i checked all those but that couldnt be it bc it only does the reving thing when the motor gets hot, not cold cranking
     
  8. 92AccordJDM

    92AccordJDM New Member

    Messages:
    76
    Likes Received:
    0
    Joined:
    Sep 7, 2008
    Location:
    ct
    hmm i know in some cases the pt3 and pt6 run theses motors fine those are stock ecus from the 90-93 accords. as far as the reving when the motor is warm im not too sure why it would be doing that case one would think if there was a air pocket of sorts it would be doing that all the time so it cant be that either.
     
  9. DaD2LnA

    DaD2LnA New Member

    Messages:
    20
    Likes Received:
    0
    Joined:
    May 3, 2008
    Location:
    Texas
    Try swapping you egr and tps wires I had this problem too
     
  10. 92AccordJDM

    92AccordJDM New Member

    Messages:
    76
    Likes Received:
    0
    Joined:
    Sep 7, 2008
    Location:
    ct
    i just finished my swap and im having tranny problems too but its most definitely the speed sensor cause my speed gauge doesnt work but i replace the motor and tranny together so im gonna swap my old speed sensor onto the new one and mine is auto as well and when i drove it it felt like it was almost in neutral with pretty much no power even if i floored it so im gonna put the speed sensor on mine and see if that helps. any update on yours i know your is a different year so somethings are a little different id check the ecu and tcu on yours.
     
  11. Hondadude141

    Hondadude141 ¿pɐǝɥ ɹn ɥʇıʍ uıop nɥɔʇɐʍ

    Messages:
    2,621
    Likes Received:
    108
    Joined:
    Jul 17, 2007
    Location:
    TX
    Lol

    This is a comma -----> ,
    This is a period ------> .

    you should use them more often, haha.
     
  12. 92AccordJDM

    92AccordJDM New Member

    Messages:
    76
    Likes Received:
    0
    Joined:
    Sep 7, 2008
    Location:
    ct

    lmao thanks ill try and keep that in mind.
     
Verification:
Draft saved Draft deleted

Share This Page