1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

JDM h22 in 92 Prelude SI, but no vtec

Discussion in 'HYBRID -> BA-BB /CA-CD' started by spaceoddity, Jun 7, 2006.

  1. spaceoddity

    spaceoddity Junior Member

    Likes Received:
    Jun 7, 2006
    So I have a 92 Prelude si h23, just got done swapping an h22. Kept my stock auto tranny. Wired up everything right, but haven't gotten rid of that external coil yet - it just dangles there. My shifter wouldn't come outta park and I don't know how to fix that (where to run wires), so I just use the key release. My problem is that vtec won't hit. At all. None. Nothing happens all the way to redline (which is still h23 redline) then when the tranny shifts, CEL 21 comes on. What the hell? I've checked and double checked my wiring, the solenoid, everything. Between the 4 best Honda guys in my town, we're all dumbfounded. Do I need a new tcu? I have the p14/p15 tcu now. Do I need the p19? I've heard mixed reviews on whether or not that tcu will even work.
  2. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Likes Received:
    Apr 27, 2005
    San Antonio, TX
    search for posts with the word "automatic" made by the member "tab"

    im sure hes answered the "how do i get outa park question" before.

    The old TCU wont shift at the right points (itll shift early) the P19 will shift at the right points. Id recommend getting the P19.
  3. tab

    tab Super Moderator

    Likes Received:
    Jan 10, 2003
    Aberdeen, Washington State
    CEL 21 will tell you why VTEC isn't working.

    The TCU won't effect VTEC at all. A better description of what has been wired would help. Obviously, something simple was missed.;)
Draft saved Draft deleted

Share This Page