1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

JDM P30 ECU with Mugen chip

Discussion in 'ECU's, Electronics, and Tuning' started by sphinx_lover, Jan 9, 2006.

  1. sphinx_lover

    sphinx_lover Junior Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Jan 9, 2006
    Hi there, i am from asia driving a civic VTI eg6 which runs a DOHC b16a2 VTEC engine.
    Recently, i have met a problem on my Rechip p30 ECU with Jun stage 3 chip which causes a continuous CEL on.
    After replacement with another so call JDM P30 ECU with mugen chip. The car works perfectly fine.
    What interest me is that this ECU has no indication of any P30 reference code on the cover.
    It has the shape of JDM(square ECU) with the following codes at the cover and a licensing MUGEN sticker
    Code XG6 and N00002 was indicated instead.
    1. Can anyone enlighten what ECU is this as i have try out several website but in vain. [​IMG]
    2. Replacing the Jun stage 3 chip on the defective p30 ecu could it work again? As i have no problem starting the car but the CEL with continue to light up.

    Hope some bros can help.
     
  2. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    54
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    pull the code.

    if its code 0, the ecu is shot.
    if its any other code, its most likely the program that was burned onto the chip, as the other ecu works w/o codes (thus, your sensors are probably ok).

    unless the new chip has something disabaled that the first one didin't. and pulling the code is the first step to figuring out.
     
  3. sphinx_lover

    sphinx_lover Junior Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Jan 9, 2006
    Thanks for the guide.
    However, what should i do to find out the codes for the defective ECU as the CEL is continuously lighted.
    After opening up the ECU, discovered that there are some burning spot at the injectors chips(which has 3 of them in the ECU). But after replacing them, the CEL is still lighted up. Although the car is still able to start, the idling is at ard 1200-1300. By switching on the aircon, the RPM drops down gradually and engines wants to die off. But after a long warm up of the engine, the car will be fine driving but will be rather dragging on the performance and unable to raise up more than 3000rpm. Becos by stepping more accelaration/pumping fuel into the throttle, black smoke starts to build up from the exhaust to indicate running rich.
    Question :
    1) Car still able to start with CEL lighted, what could be the most highly component in the ECU which is spoilt?
    2) Only the injector chips in the ECU (3 of them but i only replace 2) have been replace, but still in vain.
    3) Try copying another of my reprogram chip but still the same.


     
Verification:
Draft saved Draft deleted

Share This Page