1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

JL 250 mono issues

Discussion in 'Car Audio / Security / Electronic Accessories' started by fastacc, Oct 10, 2006.

  1. fastacc

    fastacc Doin work!!!

    Messages:
    100
    Likes Received:
    0
    Joined:
    Jun 23, 2006
    Location:
    TX
    I have one JL audio 250 mono amp on one JL 15w04 sub and it is doing some weird stuff. This is my second JL amp in about two weeks, I thought I blew the first one. Everything was fine, I lost bass to the sub and just got a flutterign out of the sub. It seemed like a 15Hz bass note even when the volume was turned all the way down. Now the amp power light is on, but no sound. This is exactly what happened to the first amp. Any ideas?
     
  2. phunky.buddha

    phunky.buddha Admin with a big stick Admin VIP

    Messages:
    28,465
    Likes Received:
    228
    Joined:
    Sep 30, 2002
    Location:
    Dallas / Fort Worth, TX
    Sounds like it's probably something external to the amp that's causing your problem. Bad ground? Bad signal? Bad power line?
     
  3. deranger

    deranger DerangedIsAsDerangedDoes

    Messages:
    132
    Likes Received:
    0
    Joined:
    Sep 29, 2006
    Location:
    Australia
    check everthing else then look at warrenty
     
  4. fastacc

    fastacc Doin work!!!

    Messages:
    100
    Likes Received:
    0
    Joined:
    Jun 23, 2006
    Location:
    TX
    pulled every piece of wire and looked over everything thinking maybe a pinched wire. Nada. I called JL and they said send them both back. $160 a piece to fix. The nearest auth. dealer is about 3hrs. Dammit. Any inside fuses on this thing?
     
  5. cheese9988

    cheese9988 Senior Member VIP

    Messages:
    1,989
    Likes Received:
    251
    Joined:
    Apr 25, 2003
    Location:
    Lowell, MA
    Ya, I'm guessing too its either how its hooked up or something else is causing it to break. Show us a pic of how you have it wired.
     
  6. fastacc

    fastacc Doin work!!!

    Messages:
    100
    Likes Received:
    0
    Joined:
    Jun 23, 2006
    Location:
    TX
    I have already unwired everything.It was a simple install though. I ran 4ga. from the battery through a pg circuit breakes to the amp. I ran the remote and rca's from the p.o.s blaupunkt cd player. Had about 1ft of 4ga.ground to the chassis. To the box it was a+ and - with 10ga streetwire. It was in there for over 2 months before I had an issue. I had the exact same setup in my old S-10 truck with no probs.
     
  7. cheese9988

    cheese9988 Senior Member VIP

    Messages:
    1,989
    Likes Received:
    251
    Joined:
    Apr 25, 2003
    Location:
    Lowell, MA
    Do you have a multimeter? If not, pick one up, please spend the extra money on a digital. (RadioShack, Sears, Fluke.com if you want top of the line) Check the resistance of the speaker with the amp disconnected, it should be close to its specifications, could possible be one reason. Push on the cone of the speaker, if its not in a sealed box it should move in and out freely and you should not hear and scraping noises. If you hear a scraping noise the material the voice coil is wrapped over is most likely deformed from overheating. Mechanical resistance will yield a lower impedance when an ac current is fed to it. Try that and tell us what you find.
     
  8. d17type-R

    d17type-R Doc Brown says

    Messages:
    210
    Likes Received:
    5
    Joined:
    Sep 21, 2006
    Location:
    Langley BC
    Try using a different Deck .....see if the problem clears up.... you said it yourself, it's a P.O.S.;) Lemme know if your "symptoms" clear up
     
  9. fastacc

    fastacc Doin work!!!

    Messages:
    100
    Likes Received:
    0
    Joined:
    Jun 23, 2006
    Location:
    TX
    ok, so I took both amps and tried them in another car. the power (green) light comes on but no sound. I guess I'll just send them back to get fixed. Oh well, thanks for the help anyways guys.
     
Verification:
Draft saved Draft deleted

Share This Page