1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Limp mode on k20z4,

Discussion in 'ECU's, Electronics, and Tuning' started by Hendri, Sep 14, 2014.

  1. Hendri

    Hendri New Member

    Messages:
    20
    Likes Received:
    1
    Joined:
    Sep 14, 2014
    Hi guys have recently done a k swop in my honda civic ran strong until the altinator belt jumped off ,car over heated.Installed an electric water pump car gained kw and torque, having problems with the k-motor and ecu.
    Running obd2c hondata k pro ecu, have traced pinouts on ecu for map censor and tps, checked continuity from censors to ecu.
    Problem 1 , flywheel friction welded to the crank shaft ( any one have the same problem)replaced crank and flywheel ,cost a packet.
    Problem 2 ,ecu came up with a fault code p0107 map sensor low voltage ,checked voltage coming in at 5v voltage on signal back to the ecu is at 2.5v with egnition on,1.2v on start up, car idling clean but only Rev's up to 4000 rpm as if in limp mode (no error codes cuming up)replacing map censor in the morning.
    Getting frustrated with all the hassles.
    Any help would be appreciated.
    Next step box of matches
     
  2. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,417
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    Got another map to try? Limp is from the engine code. Hard to buy a new map just as a hunch. I would find a Helm Manual for your motor and follow the trouble shooting for your code. If I had one, I could tell you but I've yet to acquire the electronic version. With the right searching, you'd find one online.

    Welded the flywheel from heat? Wow. Why did you spend so much on the crank and flywheel? Used block shouldn't be that expensive. How much are those CRV motors in your area?
     
  3. Hendri

    Hendri New Member

    Messages:
    20
    Likes Received:
    1
    Joined:
    Sep 14, 2014
    Hi Cafrog, looks like the map is a problem , changed it with my scoobs and it splutters on high rpm but starts easier should be finished tonight just need to do some tweeks.K parts are hard to come by my side, payd a 1200 dollars for a crank and new flywheel.
     
  4. Hendri

    Hendri New Member

    Messages:
    20
    Likes Received:
    1
    Joined:
    Sep 14, 2014
    Problem solved map sensor faulty even after testing the dam thing and the voltage being 2.5volts at atmospheric pressure and decresing under vacuum, can you believe it. :) :)
     
    Briansol likes this.
  5. Hendri

    Hendri New Member

    Messages:
    20
    Likes Received:
    1
    Joined:
    Sep 14, 2014
    O before I forget I used a b series map sensor on the k20z4 motor and it worked.
     
  6. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,417
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    We get CRV blocks for $400-900 with 40k-150k miles
     
  7. Hendri

    Hendri New Member

    Messages:
    20
    Likes Received:
    1
    Joined:
    Sep 14, 2014
    We pay 3400 dollars for a k20z4 motor our side with 25000 km on it, 400-900 dollars I'd buy 2 as spares
     
Verification:
Draft saved Draft deleted

Share This Page