1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Loss of power at high end/burning of oil (b18C1)

Discussion in 'HYBRID -> EG-EK / DC' started by Dct5289, May 19, 2007.

  1. Dct5289

    Dct5289 GT5 FTW

    Messages:
    160
    Likes Received:
    3
    Joined:
    Jan 19, 2007
    Location:
    Daphne, Alabama
    I have a B18C1 in a 93 civic cx hatch and i don't think it is running right. At high RPMs it burns alot of oil (enough to make a thin but visible smoke cloud) and it seems like i lose power past about 7000. I havent done anything to the engine as far as mods go except for exhaust and intake. The engine has really good low end torque and pulls pretty good until it starts burning oil. My compression was good last time i checked, but im going to check it again tomorrow. im going to pull the engine out and do the HG and oil seals some time this summer, But if it could be something more simple please give me your opinion.
     
  2. Dark93DX

    Dark93DX New Member

    Messages:
    466
    Likes Received:
    2
    Joined:
    Apr 26, 2007
    Location:
    B.C.
    I may be way off here, but have you checked your PCV Valve? Its a really cheap part so its worth replacing anyway. Just a thought.
     
  3. killercannible

    killercannible Senior Member

    Messages:
    633
    Likes Received:
    2
    Joined:
    Jul 17, 2005
    Could be pcv, but it would most likely leak oil too. Shake the pcv and if you hear the valve moving freely its fine, if it sounds gunked up then replace it. Also, it could be you valve seals. I would do valve seals and do a valve adjustment, you would loose power in the high r's if they are aren't right.
     
  4. Dct5289

    Dct5289 GT5 FTW

    Messages:
    160
    Likes Received:
    3
    Joined:
    Jan 19, 2007
    Location:
    Daphne, Alabama
    Thanks for the help, ill do a valve adjustment tomorrow as well as check my pcv
     
Verification:
Draft saved Draft deleted

Share This Page