1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ls b18b problems

Discussion in 'Integra' started by lostsoulzprophet, Dec 4, 2009.

  1. lostsoulzprophet

    lostsoulzprophet delslow

    Messages:
    874
    Likes Received:
    21
    Joined:
    Sep 2, 2009
    Location:
    georgia
    Ok. Here we go. I have a 93 honda del sol si with a ls swap b18b from a 95 integra running on a pr4 ecu , with a gsr 5 speed trans. The problem is it is missfiring when ever i take off in first, and push the gas at low rpms. Also is running extremly rich which can be a cause for it im guessing. Also will not pass emissions. everything emm wise is good except knox which is way to high. i mean allowed under 1k but running 3k. im thinking distributor might be going bad or needing to put bigger sparkplugs. i need help quick any suggestions is helpful:confused:
     
  2. dc4dude

    dc4dude Member

    Messages:
    904
    Likes Received:
    17
    Joined:
    Aug 12, 2008
    Location:
    chicago, il
    you still have to pass emissions for a 93 honda in georgia??? that blows. and as far as your misfire goes.... check injector pulse, firing order, spark plug gap, timing, cap, and rotor.
     
  3. lostsoulzprophet

    lostsoulzprophet delslow

    Messages:
    874
    Likes Received:
    21
    Joined:
    Sep 2, 2009
    Location:
    georgia
    o well i will check those some of them i know is not the problem. but yes still need emissions in ga for a 93 minus some counties.
     
  4. lostsoulzprophet

    lostsoulzprophet delslow

    Messages:
    874
    Likes Received:
    21
    Joined:
    Sep 2, 2009
    Location:
    georgia
    fixed the problem. coil in the distributor was going bad and one loose wire. all is good now.
     
Verification:
Draft saved Draft deleted

Share This Page