1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ls swap starting probs

Discussion in 'Integra' started by nickslscrx, Oct 2, 2008.

  1. nickslscrx

    nickslscrx Nick

    Messages:
    3
    Likes Received:
    0
    Joined:
    Oct 2, 2008
    Location:
    va beach
    i have a 90 crx wth a ls swap (b18a1) and its been bougging out on me. i cleaned the throttle body and changed the gasket cuz the dude i bought the car from used cardbord as one. after i put it back on wth the right gasket i went to start it and i started but only when i sprayed throtle body cleaner into it and when we would stop it would shut off. have any idea??
     
  2. BSTEWARD

    BSTEWARD New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Oct 2, 2008
    Location:
    Trussville Alabama
    Did you check the fuel pressure?

    Did you check to make sure there is 30 - 34 psi of fuel pressure at the injectors?
    I know this sounds stupid, but did you check to see if the Fuel pump Main Relay is working?


    just a couple of thoughts... hope this might help somehow
     
  3. dibble

    dibble New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Oct 18, 2008
    Right, BSTEWARD. Check the fuel delivery system; start with listening for the main relay to click, then your pump should click immediately after (only fraction of a second between the two), and you should be able to just barely hear your fuel pump running for about 2 seconds to prime the system and cut out. If you don't get this far okay, start looking here, as well as check the underhood fuse for the pump. First get the pump working, then check the pressure before and after the regulator, and you should be on your way.

    dibble
     
Verification:
Draft saved Draft deleted

Share This Page