1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

main relay problems w/ 97 civic dx coupe

Discussion in 'HYBRID -> EG-EK / DC' started by 97h22dxcoupe, Oct 9, 2009.

  1. 97h22dxcoupe

    97h22dxcoupe senior member

    Messages:
    332
    Likes Received:
    4
    Joined:
    Mar 29, 2009
    Location:
    Coffeyville, ks.
    relays good i turn on ignition and relay clicks once but no buzzing noise before the click could that be no power to fuel pump or some thing else by the way fuel pump is good as well,stumped any one have any ideas:confused:
     
  2. 97h22dxcoupe

    97h22dxcoupe senior member

    Messages:
    332
    Likes Received:
    4
    Joined:
    Mar 29, 2009
    Location:
    Coffeyville, ks.
    bump,need some hep guys!!!!!!!!!!!
     
  3. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    if the fuel pump isnt getting power then yeah, its probably the main relay. it has multiple circuits on it, so even if the ignition works then the relay might still be bad. When i did mine i called the local honda dealer, checked to see if they had a relay in stock, dropped the tank, checked the voltage on the pump (see your manual), when the reading came back well below norm i went out bought the relay, put it in (after much cursing) and the voltage on the pump was good.
     
  4. 97h22dxcoupe

    97h22dxcoupe senior member

    Messages:
    332
    Likes Received:
    4
    Joined:
    Mar 29, 2009
    Location:
    Coffeyville, ks.
    it has a new relay in it know ,still the same thing it either is the voltage to the pump or something else i dont know,weird:(
     
  5. 97h22dxcoupe

    97h22dxcoupe senior member

    Messages:
    332
    Likes Received:
    4
    Joined:
    Mar 29, 2009
    Location:
    Coffeyville, ks.
    need some more help,checked everything i am offically STUMPED:confused:
     
  6. 97h22dxcoupe

    97h22dxcoupe senior member

    Messages:
    332
    Likes Received:
    4
    Joined:
    Mar 29, 2009
    Location:
    Coffeyville, ks.
  7. 97h22dxcoupe

    97h22dxcoupe senior member

    Messages:
    332
    Likes Received:
    4
    Joined:
    Mar 29, 2009
    Location:
    Coffeyville, ks.
    im thinking maybe it could be a ground on thermostat housing or possibly the voltage to the fuel pump?? what do you think guys....becuz the relay clicks once and then stays warm after i put the ignition on..
     
  8. 97h22dxcoupe

    97h22dxcoupe senior member

    Messages:
    332
    Likes Received:
    4
    Joined:
    Mar 29, 2009
    Location:
    Coffeyville, ks.
    all fixed now, it was the ignition wires coming off ignition...:D
     
Verification:
Draft saved Draft deleted

Share This Page