1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Maintenance Required Light

Discussion in 'General Tech and Maintenance' started by swanny, Nov 24, 2003.

  1. swanny

    swanny Senior Member

    Messages:
    3,779
    Likes Received:
    1
    Joined:
    Jul 13, 2003
    Location:
    buck teeth and government checks, PA
    When i start my car all the lights on the dash light up as usual but the "Maintenance Required" light blinks on and off for about 5 seconds after starting it. I know that honda has set intervols for this light to appear for oil changes but here are my questions:
    1) what eltse would cause the light to come on? (im currently at 120k)
    2) how do you reset the light?
    I have also noticed some oil burnage and about 3 mpg decrese.
    this is on a 95 gsr.
    thanks in advance, swanny
     
  2. cointelpro

    cointelpro Senior Member

    Messages:
    391
    Likes Received:
    0
    Joined:
    Jul 15, 2003
    change your oil recently?
     
  3. swanny

    swanny Senior Member

    Messages:
    3,779
    Likes Received:
    1
    Joined:
    Jul 13, 2003
    Location:
    buck teeth and government checks, PA
    yup. today, and according to the sticker from the previous owner it had only been about 2,600 miles since the last one.
     
  4. b164gen

    b164gen Member

    Messages:
    58
    Likes Received:
    0
    Joined:
    Jun 1, 2003
    what kind of car is it, integra civic, on all ek civics 96 -2000 it has a maintance required light that is either green or red, its only for oil and to reset it u stick your ignition key in it and it resest back to green
     
  5. swanny

    swanny Senior Member

    Messages:
    3,779
    Likes Received:
    1
    Joined:
    Jul 13, 2003
    Location:
    buck teeth and government checks, PA
    its a a 95 gsr as i stated above and there is no keyhole to reset it.
     
  6. swanny

    swanny Senior Member

    Messages:
    3,779
    Likes Received:
    1
    Joined:
    Jul 13, 2003
    Location:
    buck teeth and government checks, PA
  7. Judo_boy_48

    Judo_boy_48 Senior Member

    Messages:
    218
    Likes Received:
    0
    Joined:
    Feb 14, 2003
    Check under your steering column where the fuses are. There might be a black box with a button on it. You have to turn on the check lights, push the button (I forget if you have to hold it) and then turn the car on. It might not be there because we did this on a 2000 gsr but thats what I can think of.
     
  8. swanny

    swanny Senior Member

    Messages:
    3,779
    Likes Received:
    1
    Joined:
    Jul 13, 2003
    Location:
    buck teeth and government checks, PA

    that worked. thanks man, i appreciate it. any ideas on wtf would cause the shitty gas milage and oil consumption other than rings and\or valve seals?
     
Verification:
Draft saved Draft deleted

Share This Page