1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Matts96HB's EJ6 Build

Discussion in 'Auto Multi-Media' started by Matts96HB, Apr 1, 2007.

  1. Matts96HB

    Matts96HB Supah Moderatah Moderator

    Joined:
    Apr 16, 2006
    Messages:
    6,137
    Likes Received:
    204
    Here's an update on the progress of my ek. Last night I tore into it and started on the LS swap. Got the motor all mounted up, and ready to go. Today is wiring and finishing up random little bits of stuff, then hopefully startup! Heres some pics.
    [​IMG]
    The D16Y7 just about ready to come out.
    [​IMG]
    No more D!! :)
    [​IMG]
    LS swap getting ready to go in with the Unorthodox Pulleys on
    [​IMG]
    Its in.

    This swap has been fairly easy, it was pretty fun to do. I cleaned the engine bay with degreaser while the D was out and the LS was being prepped. My dad and I tackled this in about 10 hours, taking our time on everything. Future plans are most likely a HMT on the LS, and im going to tear down and rebuild the D, find a crx and make a nice daily driver. Thx for lookin.
  2. Harms Way

    Harms Way Senior Member

    Joined:
    Mar 6, 2004
    Messages:
    260
    Likes Received:
    2
    Looks great! Any plans for the motor?
  3. Matts96HB

    Matts96HB Supah Moderatah Moderator

    Joined:
    Apr 16, 2006
    Messages:
    6,137
    Likes Received:
    204
    Low boost, 8-10 psi.

    I have a few questions..
    I got an OBD2 motor, and im using my stock DX harness which im told should work because its OBD2. Problem is, some of the plugs either dont reach, or I cant seem to find the place for them. Mainly on the Alt. side of the motor. I ran the wiring harness exactly where it was before, under the IM and out onto the other side. The injector plugs all reach without problem, if anyone could provide me with some info that would be great, thx.

    EDIT:
    On second thought, Im not even 100% sure if the swap is obd2 or not. Im almost positive it is obd1 now, after seeing that the P75 i was given is an OBD1 ECU. Also, when I called up the people from JDMonline.com, I was told that I was being sent an OBD2 motor, but to buy the shift linkage and throttle cable from a 95 integra LS, how can these match up if I have an OBD2 motor??
    Last edited: Apr 1, 2007
  4. BrutalB83

    BrutalB83 Brutal Moderator Moderator

    Joined:
    Jun 24, 2006
    Messages:
    11,564
    Albums:
    1
    Likes Received:
    281
    Location:
    Rochester Hills, MI
    I dunno man, it looks like an OBD2 motor to me. I have a 97 Integra, and the valve cover looks exactly the same as yours, but I noticed that on some of the older B18Bs the valve cover is slightly different.

    Anyways, good work on the swap.
  5. Matts96HB

    Matts96HB Supah Moderatah Moderator

    Joined:
    Apr 16, 2006
    Messages:
    6,137
    Likes Received:
    204
    Well, I know I have an OBD1 ecu. So, provided that JDMONLINE did give me the correct ECU for this motor, I have an OBD1 motor. Huge complaint of mine against JDMONLINE is that we asked for an OBD2 motor, he said we would get one. Such BS, now I have to get a jumper harness and start all over again.
  6. killercannible

    killercannible Senior Member

    Joined:
    Jul 17, 2005
    Messages:
    633
    Likes Received:
    2
    No, that is an obd2 ls. 94 and 95 ls motors have a different valve cover just like the 90-93 integras. example [​IMG]
  7. killercannible

    killercannible Senior Member

    Joined:
    Jul 17, 2005
    Messages:
    633
    Likes Received:
    2
    The pcv valve in the valve cover is a dead givaway, only obd2 motors have those. Also, as far as the wiring harness don't stress on missing plugs and stuff. Take your time and you will find their respective locations. There are a few under the intake manifold on the block that are hard to see. I did a b16 in my 97 ex, the ex harness is the same except it has vtec wired in already. I didn't have to cut and extend any wires at all. The only thing i had to do to get some wires to reach is removing some of the sheath around them. Also, make sure you don't swap up some of the plugs because honda used the same plugs for different sensors. For example the plug for the map sensor is the same as the plug for the evap canister(I think) if you mix these two up like i did it won't run.
  8. dbone_vtec

    dbone_vtec HONDA 4 LIFE

    Joined:
    Mar 30, 2007
    Messages:
    208
    Likes Received:
    0
    Location:
    MASS
    MATT

    YOUR DOING GREAT. TAKE THE TIME TO DO IT RIGHT

    YOUR EK IS OBD2 SO YOU NEED AN OBD2 LS INTEGRA ECU TO RUN THAT

    MOTOR CORRECTLY

    THE SHIFT LINKAGE FROM A 94 AND UP INTEGRA WILL FIT

    KEEP UP THE GOOD WORK

    HOPE TO BUILD CARS WITH MY SON SOMEDAY:drinks_drunk:
  9. dbone_vtec

    dbone_vtec HONDA 4 LIFE

    Joined:
    Mar 30, 2007
    Messages:
    208
    Likes Received:
    0
    Location:
    MASS
    The Map Clip Is The Same As The Tps Clip;)
  10. Matts96HB

    Matts96HB Supah Moderatah Moderator

    Joined:
    Apr 16, 2006
    Messages:
    6,137
    Likes Received:
    204
    Thanks for the help guys!
    I think I may have been given a different ECU, because it seems to me that it is OBD1. I tried taking out my P2E and putting in the P75 but the plugs are different, I looked at some pics of the OBD1 ECU's, and it has the same plug pattern as those. I think that might be what is throwing me off. As for everything else, ill be posting up a ton of pics, I'll need some help lol. Still have to get the throttle linkage and fuel line, plus two bolts that hold the intermediate shaft in, they are collared (sp) and are very hard to find.

    So I will need a P75 then, but the OBD2 ECU?

    And I already have the shift linkage installed, tranny feels great. Its an SiR Tranny :)

    Again, thanks for the help and encouragement!
  11. Matts96HB

    Matts96HB Supah Moderatah Moderator

    Joined:
    Apr 16, 2006
    Messages:
    6,137
    Likes Received:
    204
    Im at a loss here, plugs all over the place, but nowhere to put them on the motor!! Is there any wiring diagrams or anything that will help me out? I have everything on the distributor side of the motor hooked up except exhaust, but im really lost as to where everything else goes. I'll post pics in a few.
  12. Matts96HB

    Matts96HB Supah Moderatah Moderator

    Joined:
    Apr 16, 2006
    Messages:
    6,137
    Likes Received:
    204
    Alright, so heres what ive got so far.
    These two plugs (underneath intake manifold right now)
    [img=http://img391.imageshack.us/img391/5659/plugswtfkr1.th.jpg]
    Not really sure where these go, if anyone could identify them or let me know where to put them.

    Then these next few. Note that nothing is connected to the intake mani. and i know there should be something, so i think i know where one of them goes. If anyone can identify the others that would be great.
    [img=http://img391.imageshack.us/img391/1605/plugswtf2ib4.th.jpg]
    I really need some help here.
  13. killercannible

    killercannible Senior Member

    Joined:
    Jul 17, 2005
    Messages:
    633
    Likes Received:
    2
    The first two plugs you asked about don't go anywhere, look closely at them and you will see they aren't really plugs.
  14. Matts96HB

    Matts96HB Supah Moderatah Moderator

    Joined:
    Apr 16, 2006
    Messages:
    6,137
    Likes Received:
    204
    Thanks, realized they have caps in them :p
  15. dbone_vtec

    dbone_vtec HONDA 4 LIFE

    Joined:
    Mar 30, 2007
    Messages:
    208
    Likes Received:
    0
    Location:
    MASS
    I remember you said you used the harness off the original motor

    compare the intakes to figure it out for the three near ALT.
  16. Matts96HB

    Matts96HB Supah Moderatah Moderator

    Joined:
    Apr 16, 2006
    Messages:
    6,137
    Likes Received:
    204
    Yeah, so the only problem right now is that the plugs arent matching up. There is one that is causing a problem really. Theres one on the back of the intake manifold on the b18, that has a vaccum line running to it. Only problem is, its a square plug, and I dont have any of those on the old harness that arent being used already. I dont have that piece of the old harness to compare to either, becuse it was cut. Hopefully I can get it to work though. Bumped the starter tonight, just to make sure it was good, and it turned right over so thats good. Fuel stuff comes in tomorrow, along with the two collared bolts that were missing from the intermediate shaft.
  17. Matts96HB

    Matts96HB Supah Moderatah Moderator

    Joined:
    Apr 16, 2006
    Messages:
    6,137
    Likes Received:
    204
    The plug on the back of the intake manifold points down. Round plug, points down. It has two wires on the LS harness, but three wires on the D16 harness. What do I do here? Some sort of conversion I need to make? Any help is greatly appreciated.
  18. HATCHET_HONDA

    HATCHET_HONDA scottie fizzle

    Joined:
    Mar 11, 2007
    Messages:
    764
    Likes Received:
    10
    Location:
    hobart, indiana
    where'd you get the billet alt. pulley? looks goood!
  19. Matts96HB

    Matts96HB Supah Moderatah Moderator

    Joined:
    Apr 16, 2006
    Messages:
    6,137
    Likes Received:
    204
    Its from unorthodox racing. I got the full set from a buddy for $40. Im only using the crank and alt. pulley though :p
  20. Matts96HB

    Matts96HB Supah Moderatah Moderator

    Joined:
    Apr 16, 2006
    Messages:
    6,137
    Likes Received:
    204
    Got it started up, full 3" exhaust installed, vibrant performance muffler & resonator, metal core cat. all setup for boost.

    Runs pretty quick with the SiR tranny, i like it. :) sounds mean too.

Share This Page