1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mini-me up and running but issues

Discussion in 'HYBRID -> EG-EK / DC' started by CptWillis, Mar 24, 2013.

  1. CptWillis

    CptWillis New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Mar 24, 2013
    Hi everyone, my first post on this forum, i hope its in right place.
    Recently finished a d16y7/y8 top end mini-me swap into a 98 m/t DX, from what i understand the timing gears should line up properly but i seem to be having a timing issue.

    idle is revving up and down between about 600 and 900 rpm, and running somewhat rough, smells very rich and if i throttle it up it cuts out and dies at about 3 grand. as of right now i would say it is undriveable. the air intake is not put back on atm but i cant see that being the problem

    I have done IACV 3 to 2 wire fix and installed knock sensor, I have NOT wired the vtec selenoid and pressure switch yet, but i dont think that would be causing this, im assuming i just wont have vtec until i do it.

    this is parts list of what has been put in

    D16Y7 bottom end
    D16y8 head and intake
    y7 fuel rail,fpr and injectors
    p2p m/t ecu
    megan racing header with both O2 sensors connected

    from what i have read this seems to be a timing issue and i may need to purchase an adjustable timing gear, if so is it possible to do this without having to pull the crank pulley off again as this is a bitch now that the motor is back in the car.

    Thanks again, my apologies if ive posted this in the wrong place
     
  2. CptWillis

    CptWillis New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Mar 24, 2013
    btw the knock sensor is installed but waiting on an old ecu plug to butcher up for the pins to click it into ecu, this may be problem....
     
Verification:
Draft saved Draft deleted

Share This Page