1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Motor Is Ticking Bad.......

Discussion in 'Civic and del Sol - EG and EK' started by DelSlow89, Jan 5, 2007.

  1. DelSlow89

    DelSlow89 93 Del Sol

    Messages:
    59
    Likes Received:
    0
    Joined:
    Dec 7, 2006
    Location:
    I live in Portsmouth, VA
    Hey I just got my new el sol yesterday and i took it for a little drive. Maybe 20 miles. About half way back the motor was amking a shaking feel. i could feel it lose power sometimes just a little. but it got worse the more i drove it. I called AAA and had it towed to my shop. The head mechanic said that it maybe be either the oil has no pressure, there is a blocakage in the oil somewhere, or the lower end bearings have gone bad. the motor has 150,000 miles. so i need to know if any one knows what the problem is. Im either going to fix it or just do a swap to a dohc 1.8 type R. i haven't amde up my mind. thanx for your replies.
     
  2. DelSlow89

    DelSlow89 93 Del Sol

    Messages:
    59
    Likes Received:
    0
    Joined:
    Dec 7, 2006
    Location:
    I live in Portsmouth, VA
    Okay, My mechanic just called and said that he's just going to drop in a sankin new motor from.......i think jasper. I'm getting the 1.6 dohc straight vtech with the 160 hp.
    I'm keeping the 1.6 sohc to work on incase i come across a shell that i like.
    if any one has an answer to the ticking problem. please message me.thanx
     
Verification:
Draft saved Draft deleted

Share This Page