1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My B16a Swap Won't Rev More Then 3.5

Discussion in 'HYBRID -> EG-EK / DC' started by bossman032, Apr 27, 2003.

  1. bossman032

    bossman032 Senior Member

    Messages:
    216
    Likes Received:
    0
    Joined:
    Dec 22, 2002
    my car won't rev more then 3.5RPM.

    no engine check lights car runs fine idle no problems.

    only thing is I cant rev more then 3.5.

    my car is a STD Civic with A OBD1 motor. I tried to reset the ECU by taking out the fuse and unplug the ecu that didn't work...

    what can be causing the problem the speedometer works fine. but I cant rev past 3.5 it bogs.
    Edit: car does not BOG its just cant rev more then 3.5 it does not want to go more!!!

    please let me know what I can try..

    thanks :worthy:

    link to pictures of my swap.
     
  2. pills_PMD

    pills_PMD Super Moderator

    Messages:
    4,232
    Likes Received:
    0
    Joined:
    Sep 30, 2002
    Location:
    New Albany, OH
    you're in limp mode.. did you do the swap yourself??

    sounds like your CEL may not be functioning.. because you should def. be throwing a code.
     
  3. bossman032

    bossman032 Senior Member

    Messages:
    216
    Likes Received:
    0
    Joined:
    Dec 22, 2002
    pills_PMD,

    Yes me and couple of friends.

    First problem was the car didn't start because the dizzy was wrong. After I got the TD44-U dizzy the car started up fine idle fine after my friend checked the firing order. my car runs but it cant rev past 3.5. I tried to see if the ecu was defective but its not because my friends car is a 92-95 DX and plugged it in and it revved all the way.. So ecu is working.

    no engine check lights. car runs fine but cant rev more then 3.5.
    Thanks pills_PMD for reply.

    What else can be wrong.
     
  4. xj0hnx

    xj0hnx I wanna be sedated VIP

    Messages:
    14,172
    Likes Received:
    48
    Joined:
    Nov 10, 2002
    Location:
    C.C.TX.
    Knock sensor hooked up?Don't know why you cel wouldn't be working.Have you tried to pull codes anyway?
     
  5. kingwilly

    kingwilly Senior Member

    Messages:
    349
    Likes Received:
    0
    Joined:
    Mar 10, 2003
    Location:
    arizona
    maybe its your fuel pressure regulator....too much pressure makes your motor bog down....check all your grounds too
     
  6. b16ahatch

    b16ahatch Senior Member

    Messages:
    281
    Likes Received:
    0
    Joined:
    Nov 26, 2002
    check your distributor. i had the same problem with by b16
     
  7. honda4eternity

    honda4eternity Junior Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Apr 27, 2003
    I had the same prob. Try changing out your distributor. My b16 did the same thing but my computer threw a crank angle sensor code or something of that nature.
     
  8. bossman032

    bossman032 Senior Member

    Messages:
    216
    Likes Received:
    0
    Joined:
    Dec 22, 2002

    my distributor is brand spanking new..

    car starts and everything runs kool..

    hmm what can be wrong firing order with the dizzy..?

    everything thing is hooked up right. NO CEL.

    my friend had the same problem with his b16a he drove the car for like 50-200 miles then one day it went more then 3.5k.

    also one of my friend said it can be the TPS sencor its not throwing the Code 7...
     
  9. pills_PMD

    pills_PMD Super Moderator

    Messages:
    4,232
    Likes Received:
    0
    Joined:
    Sep 30, 2002
    Location:
    New Albany, OH
    try another ECU that you know to be good...

    do you have a p28 lying around??

    what year is the car? what kind of car?
     
  10. bossman032

    bossman032 Senior Member

    Messages:
    216
    Likes Received:
    0
    Joined:
    Dec 22, 2002

    my CURRENT ECU IS GOOD PR3 OBD1.

    I tested it on a 95 DX it worked redline at 8 or something.. So the ECU Is working.

    I am thinking its the dizzy its not on right or something..
     
  11. bossman032

    bossman032 Senior Member

    Messages:
    216
    Likes Received:
    0
    Joined:
    Dec 22, 2002
    the car is 91 STD hatch.

    Edit: Drop me a line at aim: xbossman032x

    thanks for your time and help B) :D
     
  12. bossman032

    bossman032 Senior Member

    Messages:
    216
    Likes Received:
    0
    Joined:
    Dec 22, 2002
    anyone else want to help me out..? :lol:
     
  13. redhondahatch

    redhondahatch Junior Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    Nov 19, 2002
    Did you swap all the original sensors in with the engine, the ones off the new engine could be different/broken
     
  14. Tonyd0821

    Tonyd0821 Banned

    Messages:
    5,088
    Likes Received:
    0
    Joined:
    Feb 26, 2003
    ah the joys of doing your own swap....
     
Verification:
Draft saved Draft deleted

Share This Page