1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My B18A swap is not working need HELP ASAP

Discussion in 'HYBRID -> ED-EF / DA' started by smokey345, Jul 23, 2007.

  1. smokey345

    smokey345 SwAp CrAzY

    Messages:
    47
    Likes Received:
    0
    Joined:
    Mar 17, 2007
    Ok so I dropped the engine in my car connected the starter but forgot to connect the injector resistor box. At first it wanted to turn over and I thought this could be it. Then when I connected the injector resistor box the main relay started buzzing and that didn't sound too normal and after awhile it stopped. Then I realized when I wanted to start it no click cam from the starter anymore and the fuel pump would hum when attempting to start. It continues too hum after the initial start until you put the key in the off position. I went to the junkyard and got two main relays but I don't even know if thats the problem. I also hear a clicking in a smaller relay next to the main relay. The car has never been the same since I connected the injector resistor box. WHat should I do I wired the computer for four injectors and I connected the Crank position sensor on the distributor. What could be wrong. I checked grounding and I noticed that when a wire tester was used on the engine the engine would light up. PLEASE HELP I just explained all the symptoms so everyone can get a clear sense of the dilemma I am in.
     
  2. smokey345

    smokey345 SwAp CrAzY

    Messages:
    47
    Likes Received:
    0
    Joined:
    Mar 17, 2007
    I want to get this started ASAP please help woth possible ways of fixing the problem and also when I turn the ignition to the on position the check engine light does not come on at all.
     
  3. invisibledemon

    invisibledemon Bored Moderator VIP

    Messages:
    7,402
    Likes Received:
    626
    Joined:
    Jan 15, 2007
    Location:
    Tn
    check all of your grounds
     
Verification:
Draft saved Draft deleted

Share This Page