1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My b18c swap is finished...two questions

Discussion in 'HYBRID -> EG-EK / DC' started by truoss, Jan 11, 2004.

  1. truoss

    truoss Senior Member

    Messages:
    206
    Likes Received:
    0
    Joined:
    Jul 21, 2003
    car = 94 civic hatch cx
    swap = b18c

    I added these wires: VTEC solenoid, VTEC pressure switch, and IAB solenoid
    Check engine light came on when I first stared engine. Code was 41. So, I connected the o2 sensor wire and now the check engine light is off. Engine is running great as far as I can tell. First question, is this all the wiring I need, or did I forget something?

    I test drove the car for the first time today. Everything was great, but I noticed some clicking noises when I reached a certain RPM (don't know exactly, don't have a tachometer). Is this VTEC kicking in, or what? Is it normal? How can I find out if VTEC is really working?

    Thanks a lot,
    Tristan
     
  2. Iquark

    Iquark Senior Member

    Messages:
    272
    Likes Received:
    0
    Joined:
    Dec 16, 2002
    Location:
    Mount Vernon, WA
    You should know when the VTEC kicks in, you will difinitely know...

    As for your question on the wires, What ECU are you useing?

    The clicking is probably what caused me to adjust my valves five times, and really pissed me. Finally when I was changing my oil one day, I felt my O2 sensor was loose and tightned it. After that the noise went away forever.
     
  3. truoss

    truoss Senior Member

    Messages:
    206
    Likes Received:
    0
    Joined:
    Jul 21, 2003
    jdm p72

    So, that clicking noise is not coming from VTEC kicking in?
     
  4. dohch22a4

    dohch22a4 Senior Member

    Messages:
    1,744
    Likes Received:
    0
    Joined:
    Feb 5, 2003
    Location:
    Spokane, WA
    There is a slightly audible "click" when VTEC engages, but it should be only one click and only at 4400 RPM. If it is a constant ticking, you probably need to adjust your valves. My B18C ticks at idle, but not any higher, I should probably get off my dead fat ass and adjust them, but whatever.
     
  5. JDMilan

    JDMilan Senior Member

    Messages:
    6,730
    Likes Received:
    0
    Joined:
    May 11, 2003
    Location:
    Boca Raton, FL
    No Cel's , which is good


    It sounds like your running fine, not sure about the clicking though.
     
Verification:
Draft saved Draft deleted

Share This Page